Search Language Indexer
Problem reported by John Marx - 5/12/2019 at 5:32 PM
Resolved
I found this unique setting and thought - awesome. We just built a brand new server and migrated 100 domains over this weekend. Propogated this to every user. My problem is that everytime I go in to the User Defaults it resets this back to "Generic Indexer" rather than "English" that I set it to. This means all new users will get the generic indexer.

Now comes the question of what does this do? Is it truly designed for english as users complain they can't find things like "bill", "deposit", etc. in email body/subjects. They show us this is there and when they search no results are found. How can we get it so results are found? We have reindexed the users still with no success.

2 Replies

Reply to Thread
0
Webio Replied
Side question: does search language indexer language list is closed? For example there is a Czech language but no Polish (which I would use on my end).
0
Kyle Kerst Replied
Employee Post Marked As Resolution
Hello and good afternoon. The Search Language Indexer does not normally need to be adjusted as it includes support for most characters by default. However, adjusting the setting may net better results when users view the interface primarily in another language. This is detailed in our SM online help as well:

  • Search Language Indexer - The language that the Lucene indexer will index against. In most cases, Generic Indexer is the best selection as it incorporates English and common umlauts. However, if the interface is viewed in certain languages, such as Chinese, Japanese, or Korean, this setting should specify the language for better indexing results.
As to the language options being open/closed, I believe this process is open to external teams helping us include additional translations. Please reach out to our sales team to get in touch regarding language/translation files. Thanks!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread