6985: Web page opens to Localhost 9998 after install
Problem reported by Neal Culiner - 2/16/2019 at 7:32 AM
Submitted
I see that 6985 released and a lot of work on anti-spam, hoping for the best, thanks for all that. I don't know the difference in the Full installer and MSI installer, I chose full. Would help to show the differences on that popup as I'm sure no one knows and your dialog doesn't tell us. Anyways, did the install and after the install it launched a browser to localhost 9998 as if this was the prior SM versions where you had your own web server. With SM NoName (17?) I think it's IIS only now so why did localhost launch?

I have Message Sniffer licensed but the default anti-spam doesn't set it. I suggest taking your reset one step further and if someone has anti-spam additions licenses activate them. How many have a licensed anti-spam from you that's sitting unused?

6 Replies

Reply to Thread
0
David Fisher Replied
Hi Neal,

  The difference between MSI and EXE were talked about in this post :


-dave
0
Steven Belsha Replied
This can be fixed quite easily by opening your IIS manager and adding a binding for localhost port 9998
0
Neal Culiner Replied
Why would I want to use a localhost entry when the installer even has you configure a binding? Seems like a bug. 

EXE vs. MSI - the dialog for downloading should include all information that any user may question. We should not have to google it or post here asking what the difference is. Present it to the user via a good UI.
0
Binesh Shammunni Replied
Neal Culiner,

The changes smartermail done long back, you should change Steven recommendation either http or https with port 9998 so that your admin console able to open localhost environment. 

Thanks
0
Neal Culiner Replied
Did I miss this in the documentation? Anyone have a reference of ST's direction to add this? I'll review again.
0
Binesh Shammunni Replied
1.png


Do not allocate any IP or 127.0.0.1,  The above setup work http://localhost:9998/ or https://hostname:9998/  I prefer second option because nowadays most of the browser required https so that your application run smoothly

I hope Neal Culiner clear clarifications

Reply to Thread