Incomming Gateways still broken in Build 6964
Problem reported by Bruce - January 30 at 6:00 AM
Resolved
Notes for Build 6964 say :

  • Fixed: SmaterMail Gateway Mode for Outgoing Gateways only accepts hostnames not URLs.
However, this is still broken for Incomming Gateways and you can only add a hostname and not a URL, which means you can not add an HTTPS:// URL.

It addition Web Service user verification does not work and SMTP connections always returns a 550  No such user here response if this is enabled.

The 'save' option only becomes enabled if you update the SmarterMail URL.


18 Replies

Reply to Thread
0
Alex Carnot Replied
Employee Post
Hi,
I have confirmed this issue and have added it to our bugs list for inclusion in the next public release.
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bruce Replied
Thank you
0
Webio Replied
https://portal.smartertools.com/community/a91576/smv16-smv17-incoming-gateway-completely-broken.aspx

This is also being covered under 17C-23AA41AE-000A ticket (original ticket was about other thing - spoofed messages being relayed to main server) but not it is also about this since this issue can't be tested on v17 because of issue you've already mentioned.

On the other hand Bruce do you use SpamAssassin? I've tested SMTP Verification method with SMarterMail Gateway Mode disabled and messages where relayed correctly to main smartermail instance but no SpamAssassin checks where made.
0
Bruce Replied
Hi Webio, I think we use to chat years ago on the old Helm Control Panel or DotNetPanel forums. I had the username Borg back then.

I have only upgraded one of the backup MX Servers to SM17, the primary mail server with 12,000 mailboxes is still on SM16.

I use Cyren and MeesageSniffer on the primary, but on the backup MX server just use RBL lists to block spam.

The Reverse DNS also seems to be very buggy in SM17 so disabled that last week as it was causing a lot of issues. Not sure if it was the DNS Cache in SM17  that was the problem or the RDNS lookups that SM17 was doing as once it started for a domain you would just get a 503 error when connecting to the SMTP service till SM17 service was restarted.

I have configured the backup MX server to accept all emails for now and delete anything with a spam score over 30 as SM17 does seem to work well as a gateway server at present due to the bugs which meant emails were not being delivered.

I have learnt never to upgrade to a new major version of smartermail for at least 6 months, so am keeping the primary mail server and customer mail servers on SM16 for now.
1
Webio Replied
DotNetPanel for sure. When it comes to v17 I've upgraded my main instance from v15 to v16 and after about a week to v17. Except issue with reactivating enterprise license I didn't had any major issues. CPU and mem usage are higher than v15 but probably thats the cost of using new versions.

For now my biggest issue are incoming gateways which in v17 does not work and in previous versions they relayed spoofed messages (FROM addresses from local domains being sent from remote servers) to main smartermail instance.
0
Alex Carnot Replied
Employee Post
Hi,
This has been fixed and will be included in the next public release.
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Webio Replied
Please stop marking posts as resolved before you check that problem has been really resolved :). Validation error is only something on the side with incoming gateway issue. Anyone can edit json settings file and replace incoming gateway SmarterMail Gateway URL and start service using this edited URL so this was only GUI problem. Real problem is mentioned also in initial post od this thread and it is:

It addition Web Service user verification does not work and SMTP connections always returns a 550  No such user here response if this is enabled.
and this is still broken (I've just checked using latest build from yesterday).
0
Webio Replied
Bruce one more thing. When you upgrade to v17 xml configuration files are being left intact (with some addition like _old to their name) so you can completely remove v17, install v16, stop it and replace configuration file. Thats what I've done when I've upgraded my 3 incoming gateways to v17.

EDIT: Files needed to return to v16 gateway: spamConfig_bak.xml mailConfig.old.xml (I'm not sure about .old.xml since I could name it that way)
0
Bruce Replied
Thanks, Webio, that's useful to know.

Judging by how buggy SM16 was when it was released I think I will wait till August before I upgrade to SM17.
0
Bruce Replied
Build 6970 does partly fix incoming gateways in that the save is enabled on changes and you can enter a URL.

User Verification using Web Service is still broken when using 'Back XM' gateway mode.
1
Webio Replied
Can someone unmark this as resolved?
0
Sébastien Riccio Replied
+1

ST Support told me this would be fixed in the next build (which is out now). But is seems there is nothing about it in the changelog :'(
0
Bruce Replied
+1 Incomming Gateways are still broken  
1
Andrea Rogers Replied
Employee Post
In Build 6995 (Feb 25, 2019), I see in the release notes:
Fixed: Web service user verification does not work for incoming gateways.

Bruce, Sébastien, Webio... Can you please upgrade and let me know whether this issue has persisted in your installation? For now I will mark this thread as Resolved until I'm told otherwise. 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
877-357-6278

www.smartertools.com

1
Jamie Money Replied
I can confirm for me that Web Service user verification is fixed as of 7008 (I skipped over 6995)
0
Sébastien Riccio Replied
Hello Andrea. Thank you for the info. I can't check it at the moment as we paused our v16 -> v100 migration at the moment.
I will for sure try it out on our v100 migration sandbox environnement and will report here the results.
1
Webio Replied
WebService verification method works fine now.
0
Bruce Replied
Incoming gateways are now working for me also

Reply to Thread