v17 Activation Failure
Problem reported by Michael Rigsby - December 3 at 2:18 PM
Resolved
Just installed 6911 this morning (upgrade from 16) and activation fails. Below is a snippet from my diagnostics page. Is anyone else experiencing this or anything similar? I already opened a support ticket however I have not received any update on the status.

Internet Connectivity
Passedresolve yahoo.com
Failedhttp to yahoo.com

Notes: The underlying connection was closed: An unexpected error occurred on a receive.
Passedresolve google.com
Passedhttp to google.com
Product Checks
FailedActivation ECHO A0

Notes: System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.ArgumentException: The specified value is not valid in the 'SslProtocolType' enumeration. Parameter name: sslProtocolType at System.Net.Security.SslState.ValidateCreateContext(Boolean isServer, String targetHost, SslProtocols enabledSslProtocols, X509Certificate serverCertificate, X509CertificateCollection clientCertificates, Boolean remoteCertRequired, Boolean checkCertRevocationStatus, Boolean checkCertName) at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result) at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size) at System.Net.ConnectStream.WriteHeaders(Boolean async) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetResponse() at SmarterMail.Web.Controllers.AboutController.VerifyActivationEcho(StringBuilder sb, Int32 server)
FailedActivation ECHO A1

Notes: System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.ArgumentException: The specified value is not valid in the 'SslProtocolType' enumeration. Parameter name: sslProtocolType at System.Net.Security.SslState.ValidateCreateContext(Boolean isServer, String targetHost, SslProtocols enabledSslProtocols, X509Certificate serverCertificate, X509CertificateCollection clientCertificates, Boolean remoteCertRequired, Boolean checkCertRevocationStatus, Boolean checkCertName) at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result) at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size) at System.Net.ConnectStream.WriteHeaders(Boolean async) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetResponse() at SmarterMail.Web.Controllers.AboutController.VerifyActivationEcho(StringBuilder sb, Int32 server)
PassedConnection to SmarterMail Service
FailedProduct Activated?
PassedIIS Worker Count: 1

20 Replies

Reply to Thread
0
Larry Duran Replied
Employee Post
Hello Michael, we are currently working on a fix for this issue.  I believe there are others who have experienced this issue as well.  Since you already opened up a support ticket keep an eye out for a fix that should be coming soon.  Thanks!
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Michael Rigsby Replied
Thank you. This would have been good to know in the ticket I opened 3.5hrs ago. 
0
Larry Duran Replied
Employee Post
Hello Michael, we've been troubleshooting this without any update until about the time I answered this post.  We're actually in the process of testing locally before we send out a fix so if all goes well this issue will hopefully be resolved.  On a side note, when I responded to this thread I also let support know that I updated you on the progress of this issue so they did not know of any possible fix until recently.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Michael Rigsby Replied
When you say "should be coming soon" what kind of time frame are we talking about? My email is stalled since "License limits exceeded" when I can not activate. 
0
Michael Rigsby Replied
Ok, great. Thank you for the further update
0
Larry Duran Replied
Employee Post
The fix should be live on our website now.  If you want to download and install and see if it works for you so we can update this post.  Thanks.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Michael Rigsby Replied
Great. Looks like its all working now. Thank you for your help. 
0
Larry Duran Replied
Employee Post
Great!  Thanks for the quick test and response.  I'll tag this issue as fixed.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Dave Feuer Replied
This issue just cropped up on one of my boxes.
-Dave
0
echoDreamz Replied
Dave, did you download the 6911 build again? It seems like ST is just re-releasing the same build number with changes.

Christopher

0
Dave Feuer Replied
I downloaded it this morning, but I'll try it again.

0
Dave Feuer Replied
Tried again, same error. It's just a test server so not a big deal.
-Dave
0
Tim Uzzanti Replied
Employee Post
Yea, but if its happening for you it might happen for someone else.  We did have a few customers with activation issues and were able to resolve them but there might be something still outstanding.  Fortunately we haven't had an issues that impacted a bunch of customers.  Fingers crossed.  Up to you if you want to continue working with us.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Dave Feuer Replied
If you think it will help I can open a ticket and let you take a look, but since it's a testing box it's possible that it is something we did so I don't want to waste your time. 

-Dave
0
Dave Feuer Replied
So the fix for another issue also fixed this: I applied this to the test box and the activation is now clean.


If you want I can roll back to the other version and see if the issue reappears.

-Dave
0
Gregory Magnin Replied
Hi

I had activation issues and now always the same error in the diagnostic page, for information.
I hope it will be an official new release soon ...

Greg
0
Shivam Parikh Replied
Really weird issue with ST not doing a good job on releasing builds to confuse people.

On the actual launch date the build number was 6910 then it became 6911 (with the same changelog) and 6910 was removed from both SmarterMail and Starter Track. Then it seems 6911 has two updates for the same build. So its hard to know if I need to upgrade from 6910 to 6911 and if so why as 6910 upgraded from SM 16 smoothly.

I dont like the fact that ST is hiding transparency in its versions. It's almost as if its trying to hide bugs or patches so that certain people who posted this week about licensing issues and pricing issues, dont have a reason to get upset. I am already upset though as I dont even know that they issued 6911 until I randomly visited the website today.I downloaded 6910 on launch date and that was the download available with the same changelog. 
1
Tim Uzzanti Replied
Employee Post
Shivam,

I can see you have 4 posts in the community about this and a ticket into support .  There was no attempt to hide issues or some grand conspiracy.  We had an activation issue that affected a handful of people.  For those who saw the activation issue, they opened a ticket or communicated in the community.  We attempted to work with every individual and get them up and running. We did about 36 hours straight starting on Sunday.  Every system was updated, and tested (Billing Systems, Internal Management Systems, Activation Systems, My Account, Websites, API, All Products, etc).

Yea, probably should have had a release note and updated all areas accordingly.  To be honest, everything is a blur and seemed like all the same day etc.  It was a small fix and again only affected a handful of people and we were hyper-focused on getting anyone with issues up and running.  If you didn't see the bug, it had no bearing on your install.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Anthony DePinto Replied
We received the same issue when upgrading  a gateway to v17 this morning.   We have a support ticket in, but didn't know if there was anything to resolve in the meantime?  Right now the CPU on this server is pegged at 100% with very low activity so I'm hoping the CPU spike is due to this issue.  It's processing mail, just very slowly.

it also looks like the product isn't activated as mentioned above.  
0
Tim Uzzanti Replied
Employee Post
Actually, I was just briefed on your ticket. Looks like it came in a couple hours ago with you sending an update in 20 minutes ago.  It has been assigned to an agent and they are talking to the developers.  If you want to create another thread for the issue you can.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread