SamrterMail 17 issues: 1 - High CPU 2 - Aliases and Groups doesnt work 3 - domain forward gateway doesn't work 4 - IDS Blocks count always increse
Problem reported by Gabriele Maoret - November 7 at 1:30 AM
Submitted
We have updated our SmarterMail Server from latest v.16.x to latest 17.x.

Issues:

1 - the CPU usage of the smartermail service increase from 5-15% to 40 - 70%

2 - we have many aliases and groups configured four our clients. After upgrade many of that fails with this error message: "550 name@domain.com  no such user here"

3 - we have a configured Domain Forward Gateway for 1 single domain. After upgrade it stop working ad every mail sent to that doamin fails with error similar to point 2: "no such user here"

4 - in MANAGE page, the IDS BLOCK always increase and never go down to "0" even there isn't blocked IP



7 Replies

Reply to Thread
0
Gabriele Maoret Replied
Addendum point 2:
- Aliases sometime works sometime not
- Groups are never working. I have also tried to create new groups, but the issue is the same...
0
Gabriele Maoret Replied
I had misunderstood the use of "USER GROUPS" ... These are not distribution groups ... My Fault
To create distribution groups I must use ALIASES with multiple target addresses...

The other issues remain...

0
Gabriele Maoret Replied
I deleted and recreated all the ALIAS (and the groups that are now ALIAS, of course ...) and now the ALIAS all work.

So point 2 is solved, the other problems remain

0
Andrea Rogers Replied
Employee Post
Hi Gabriele, 

Regarding #1... In SmarterMail 17.x, we've updated the indexing format. On your initial upgrade to 17.x (from any earlier major release), ALL user accounts will be reindexed in order to utilize this new format. As the reindexing occurs, you will see a temporary spike in CPU. However, please note that a user's experience and the overall server performance should not be negatively impacted, as the indexing thread is prioritized lower than all other threads. In addition, users will still be able to search while this one-time bulk reindex occurs. This is because a user's account will use the old indexing format for searches if the reindexing has not yet been performed for their account. As soon as their account has finished reindexing, it will simply switch to the updated format.

This information should have been noted in our BETA threads previously, and I apologize that it was not. I've since added this information right next to the installer link for the BETA release announcement thread (since it doesn't impact just a singular build). The CPU spike is expected and will rectify itself once the reindexing is done. 

I hope this helps!

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
Gabriele Maoret Replied
Thanks Andrea, this is usefull to know!
by the way, is it normal that reindexing is still working 5 days after upgrade?

We have about 200 Mailboxes with about 150 GB of storage used...
0
Andrea Rogers Replied
Employee Post
Hi Gabriele,

We spread out the indexing in batches so it's not all done at once, so it's possible that the reindexing would still be processing after 5 days. There are two ways to tell if you're still processing the bulk reindex: 

  • Log in as a Domain Admin and head to Settings > Accounts > Users tab. Click through your users to view the Search Language Indexer setting. If their account has finished reindexing, 'Generic Indexer' will be selected. If they haven't been reindexed yet, 'Old' will be selected instead. (As soon as a user is reindexed, their Search Language Indexer setting will switch to Generic Indexer.)
  • Log in as a System Admin and head to Manage > Troubleshooting > Mailbox Indexing. You'll find a list of users that are currently being indexed.
Please also feel free to turn your Indexing logging to Detailed so you can see any related errors. You can do this by heading to Manage > Troubleshooting > Options tab. 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
Andrea Rogers Replied
Employee Post
Regarding the other issues you posted...

3 - we have a configured Domain Forward Gateway for 1 single domain. After upgrade it stop working ad every mail sent to that doamin fails with error similar to point 2: "no such user here"
We'll need our Support team to review this issue one-on-one. 

4 - in MANAGE page, the IDS BLOCK always increase and never go down to "0" even there isn't blocked IP
Do you mean that the tabs IDS Blocks always show a number, despite no blocks being shown? Or does an IP entry show Time Left but the IP is not actually blocked anymore? 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

Reply to Thread