SM 15.x Default domain for webmail login
Question asked by Paul Blank - July 28 at 8:42 AM
Answered
How do I set the default domain for login via webmail e.g.
 
Either username@domain.com or username [without the domain name]
 
are accepted as login names for one particular domain on an SM v15 server?
 
I have this set just right for an older version, but don't know where the setting is. Waitasec: is it the "Hostnames" setting (Bindings/Hostnames) as related to IP address?
 
Thanks!
 

9 Replies

Reply to Thread
0
Paul Blank Replied
Nope, it wasn't that setting. Anyone?
 
Cheers.
 
0
Andrea Rogers Replied
Employee Post Marked As Answer
Hi Paul,
 
To allow users to log into their domain's site with just their username, you'll need to configure a host header for that site within IIS. You can follow these steps: Set up Host Headers. If your host headers are set to point to mail.EXAMPLE.com, any email address on the EXAMPLE.com domain would be able to sign in without the domain designation.
 
Please let me know if you have any questions! 
 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
Paul Blank Replied
Not enough (or even correct, far as I can tell) information at those links.
 
I would like specific instructions about how to set this up, so that entering [login_name] for a particular domain is the same as [login_name@particulardomain.com]
 
In this case, IIS 8.5 on Server 2012 R2, SM v15.x
 
0
Von-Austin See Replied
Employee Post
Paul,
 
The domain detection is based on the URL the end user hits, there is no configurable setting.
 
For example, if you client reaches their mail server at http://mail.customersdomain121212.com and enter the username as 'Joe' the account that's authenticating is technically joe@customersdomain121212.com.
 
If the customer hits mail.customerdomain151515.com and attempts to sign in as 'Joe' the account will attempt to authenticate as joe@customerdomain151515.com.
 
Please note that this functionality will not work with POP\IMAP clients, but should work with EWS\EAS protocols in addition to the web interface as long as the e-mail client sends the appropriate connection information based on the server entered in the connection settings. 
 
Bindings\Hostnames are related to this functionality only in regards to what hostnames are setup to listen within your IIS bindings. 
 
I hope this helps clarify.
 
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Paul Blank Replied
Thanks for the info, Von.
 
Changing the hostname in SM (Settings/Bindings/Hostnames) from mydomain.com to email.mydomain.com (matching the FQDN in IIS), then stopping and restarting SM and IIS Windows services, to be safe, did the trick.
 
The SM domain name remains (and should remain, in this case) mydomain.com.
0
Paul Blank Replied
Yes it is that setting. It seems to just need the FQDN to make it right. Scroll down in this thread.
0
Paul Blank Replied
8/8/2018 7:54 am: The Hostname setting in SM has a lot to do with it.
0
Paul Blank Replied
See below.
0
Paul Blank Replied
Still not sure now that the Hostnames entry makes a difference, but it's working. I didn't have a Hostnames entry for one of the domains, and it still seemed to work. I am using different IP addresses on the SM server machine, and am redirecting from a different WAN inbound port to the HTTPS port at that 2nd IP on the SM machine for the 2nd domain (in this case port 4435 - same inbound WAN IP address, different port - is being redirected to HTTPS 443), and it works.
 
And the domain outbound IP setting in SM is remaining the same, as I still want it to be that address, outbound.
 
A little confusing, the Hostnames thing, but it's working.
 
BTW the firewall is a Sonicwall TZ400. Setup is complex, but in the end, quite logical. I've been working with these for years; they have gotten even more complex, but they do work well.
 

Reply to Thread