Check MX Domain
Question asked by John Marx - July 24 at 6:32 AM
Answered
We have a client that left due to not liking the new v16. I am fine with that. The problem is they have moved to gmail but haven't finished migrating their old domain.com off of our server. We can't email them because we are emailing user@domain.com and it is hitting the SmarterMail server still rather than the gmail server. 
 
How can we keep domain.com on our server but actually REACH the gmail server? This seems more of a bug as thinking the reverse if we are migrating someone too us we would want the domain on our server, migrate, and then migrate the client.

3 Replies

Reply to Thread
1
Andrea Rogers Replied
Employee Post Marked As Answer
Hi John,
 
When editing the domain, there is an option on the Email card for Inbound Message Delivery. Change this to "External (use MX record)" and you should be all set. You'll probably want to keep "Delivery locally if user exists" disabled. Here's the setting's definition from Online Help:
 
Inbound Message Delivery - Administrators can specify the domain location for incoming email delivery. This allows you to specify whether the domain is hosted locally or partially/entirely on an external server. The following options are available:
 
  • Local - Select this option if the mail server is hosted locally.
  • External (use MX record) - Select this option if the mail server is hosted partially or entirely externally. Messages will be delivered based on an MX lookup. Select the option "Deliver locally if user exists" to perform a local delivery instead of external if the user exists locally.
  • External (use host address) - Select this option if the mail server is hosted partially or entirely externally. Messages will be delivered to the specified host address. The host address can either be entered as an IP address or the Fully Qualified Domain Name (FQDN), such as mail.yourdomain.com. Select the option "Deliver locally if user exists" to perform a local delivery instead of external if the user exists locally.

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
Webio Replied
I had to disable it because I had occasional problems with delivery but it is still being checked (someone from ST could recheck 21F-214517A6-0B59 which was closed because of inactivity and developers developing SM 17.x).

There is one probably issue in this scenario and it is related to having local configuration of domain which points to other MX servers and receiving mails from this domains to other users located on this server.

So in short:

domain1 is created locally but it points to different MX servers
domain2 is located local on SM server with proper MX configuration

Now domain1 which has local configuration but is handled on other server is sending email from remote SMTP server to local domain2 which is configured on SM server with domain1 configured. Domain2 sender will probably receive user not found or 550 Authentication is required for relay because of existing local configuration.

IMHO when setting "External (use MX record)" is used this should be also handled for incoming mail because of this scenario.

I will not even mention that this has also additional issues when using incoming gateway with user verification using web service.
0
Andrea Rogers Replied
Employee Post
Thank you for these details, Webio.

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

Reply to Thread