SmarterMail 16.3.6726 Install Issues
Problem reported by Joe Wright - June 2 at 5:59 AM
Submitted
After installing SmarterMail 16.3.6726 we had to immediately revert back to a previous version. We were not able to access the IIS site and Clamd would continuously fail.
 
clamd Error Messages:
 
Faulting application name: clamd.exe, version: 0.100.0.0, time stamp: 0x5ac421dd
Faulting module name: VCRUNTIME140.dll, version: 6.2.9200.17313, time stamp: 0x5507a832
Exception code: 0xc0000135
Fault offset: 0x00000000000e2100
Faulting process id: 0x4130
Faulting application start time: 0x01d3fa6343ea045a
Faulting application path: C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam\bin64\clamd.exe
Faulting module path: VCRUNTIME140.dll
Report Id: 81968f25-6656-11e8-93fe-005056821d9a
Faulting package full name: 
Faulting package-relative application ID: 
ASP.NET Error Messages
 
Event code: 4011 
Event message: An unhandled access exception has occurred. 
Event time: 6/2/2018 6:17:23 AM 
Event time (UTC): 6/2/2018 11:17:23 AM 
Event ID: 560579e84f414bf7badae7fdd779fa57 
Event sequence: 50 
Event occurrence: 1 
Event detail code: 0 
 
Application information: 
    Application domain: /LM/W3SVC/7/ROOT-1-131724118208820494 
    Trust level: Full 
    Application Virtual Path: / 
    Application Path: C:\Program Files (x86)\SmarterTools\SmarterMail\MRS\ 
    Machine name: NVT-HOSTING-02 
 
Process information: 
    Process ID: 12276 
    Process name: w3wp.exe 
    Account name: IIS APPPOOL\SmarterMail 
 
Request information: 
    Request URL: /interface/root 
    Request path: /interface/root 
    User host address: xxx.xxx.xxx.xxx 
    User:  
    Is authenticated: False 
    Authentication Type:  
    Thread account name: IIS APPPOOL\SmarterMail 
 
Only reverting back to the previous v16 minor version we had fixed the issue. Anyone else seeing similar issues?
 
 

6 Replies

Reply to Thread
0
Mars _ Replied
Same here!
Also permission issues with the MRS/App_Data folder
and
Faulting application path: C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam\bin64\clamd.exe
 
After settings the permissions still a diagnostic error:
Failed /App_Data/ Folder Permissions Test
 
 
2
domains Replied
Getting the same error after updating to SmarterMail15.7.6726 - missing VCRUNTIME140.dll, reinstalled the dll, but still getting the error
0
Scott Forsythe Replied
I'm also running SM 15.7.6726 on a Windows 2008 server. I'm receiving this same error in the System - Event Viewer:

Application popup: clamd.exe - System Error : The program can't start because VCRUNTIME140.dll is missing from your computer. Try reinstalling the program to fix this problem.
0
Scott Forsythe Replied
I corrected the problem. Here's what I did:
1. Stopped SmarterMail
2. Downloaded and installed Microsoft Visual C++ 2015 Redistributable
3. Rebooted
4. The clamd.exe error is no longer reported in the System - Event Viewer. Clam is also running with no problems.
0
domains Replied
I followed the exact same steps as Scott, but still getting the clamd.exe error
0
Scott Forsythe Replied
A few ideas:
1. You could try re-installing SM. After you uninstall SM, try renaming the Clam folder. My Clam folder is located in C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam. This will give Clam a fresh start.
2. You may need the x64 and x86 version of Visual C++ Redistributable. You can confirm with SmarterTools.
3. Open ticket with SmarterTools.

Reply to Thread