Deliver to Office 365 goes to spam.
Question asked by Oskari Koivisto - February 21 at 6:48 AM
Unanswered
Hi,
 
we have newly setup Smartermail server and hosting currently about 70 domains. We have a problem of getting our mails through to Microsoft Office 365. All the mails from all domain goes to SPAM. We use SMTP TLS with wildcard certificicate, it should be ok since it works with other mail providers?
 
Other thing is that when checking our server with MX Toolbox Test mail server, it warns that we don't have TLS enabled. We advertise it but it's not enabled? How do I enable it?

4 Replies

Reply to Thread
0
John Marx Replied
Few things:
 
Test your SSL on the server with SSL Labs - https://www.ssllabs.com/ssltest/
Do you have SPF, DKIM, and DMARC setup according to MXToolbox? When we didn't have that we noticed some email hitting spam depending on where we send to.
0
Oskari Koivisto Replied
Hi,
What exactly I should be looking from there? We got Grade B.
SPF, DKIM and DMARC tests are ok.
0
John Marx Replied
A grade should be an A with TLS enabled. When I've seen B+ or lower I see companies like Microsoft, Google, etc. marking them as spam due to the fact that they have older insecure protocols. I don't necessarily agree with that but that is a factor.

Also, do you have a reverse DNS setup? That could throw you in. They try to make lives better by stopping spammers. An option could be contacting them and asking WHY so you can adjust. It could be something simple like the domain is too new, there used to be a spammer on your IP address (or still is on your class C), etc.
0
Oskari Koivisto Replied
But receivers don't test what protocols we have open..? We have TLS now active so the MX toolbox also recognize it too. But still, O365 spam..
We have Reverse DNS setup also.

Reply to Thread