Custom Folder for Login Screen background Images is not used
Problem reported by Rod Strumbel - December 28, 2017 at 11:26 AM
Resolved
Latest version of SM 16 installed
Trying to setup custom background images rather than using the predefined set that comes with SM.
 
Logged in as the system admin
General settings
Login Background set to:  "Custom Image Folder on Server"
Entered the folder path:   E:\BackgroundImages 
And dropped a half dozen images in there
 
If I use the "Preview Login" option, it looks as I would expect it to.
Save and then goto the login page... still using the default images.
 
Flushed browser cache, no difference, completely restarted browser... same.
Restarted IIS service, same issue.
 
Does this just not work ?

4 Replies

Reply to Thread
0
Rod Strumbel Replied
I should add that changing the "Custom Login Text" updates IMMEDIATELY to the login screen, not sure why all the other settings on this screen wouldn't as well.
0
Robert Emmett Replied
Employee Post
Make sure your IIS worker has permission to access the custom background image folder.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Rod Strumbel Replied
I figured this out, it was an issue with browser caching.  Haven't seen a browser cache background images for pages before (normally those are set to be non-cache-able so that they can be updated via script) but that was the cause.
Cleared the browser cache  and immediately my custom folder images appear.
 
Almost feel dumb it was such a simple solution.  :)
0
Brian Davidson Replied
Hmm. I have had the same issue for a while and browser cache doesn't seem to matter. The server keeps sending the same background image. I've asked about this elsewhere and the IIS worker permission comment is all I've seen (not the issue for me). It seems to randomly change images over the course of a day or two?

Reply to Thread