UK Date Format
Problem reported by Mark Milton - 12/13/2017 at 9:13 AM
Resolved
Hi,
All dates show as US format MM/DD/YY instead of UK DD/MM/YY

Server is set to UK
User is set to UK
Device is set to UK
 
I have double checked all the formatting which are all set to UK but still shows as US. Is this a know bug?

Can it also be made if the system is set as UK it defaults to UK when first setting up a user so they don't all need to change to UK and GMT. All my clients are UK based 

Mark Milton
Pro Tech North
Web: www.protech-north.co.uk
Email: mark.milton@protech-north.co.uk
Tel: +44 (0)1261 838282
Web Design & Web Hosting

10 Replies

Reply to Thread
0
Matthew Hall Replied
Any update on this?

It might sound trivial to you US guys, but when we see 8/1/2018, we read that as 8th of Jan 2018. We have to remember that we're reading the date in smartermail so have to transpose the date manually. 
Matthew Hall
System Administrator
Farrell Heyworth
0
Mark Milton Replied
I haven't tried SM17 but I really hope its fixed in SM17

Mark Milton
Pro Tech North
Web: www.protech-north.co.uk
Email: mark.milton@protech-north.co.uk
Tel: +44 (0)1261 838282
Web Design & Web Hosting

0
Robert Emmett Replied
Employee Post Marked As Resolution
Mark / Matthew, if you are running SM 16.3.6915 or later you should be able to select English (United Kingdom) as the language when logging in or set it in the user account settings.  It will then use the UK date/time formatting.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Matthew Hall Replied
OK, was only using 16.3.6897. Will try thanks.
Matthew Hall
System Administrator
Farrell Heyworth
0
Trevor Rowley Replied
We have the same problem. Upgraded last night to very latest release and lost all our customer's sub-folders and so had to revert to previous snapshot.

We then updated to 16.3.6915  which was successful and we still have all the folders, but there is no English (United Kingdom) option shown in the language choices.

Trevor Rowley
Optix Software
0
Robert Emmett Replied
Employee Post
Trevor, check the MRS\App_Data\Translations folder.  If there is no en-GB.json file, then you can simply make a copy of the en.json file and rename it.  No need to restart the mail service; just refresh the browser.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Trevor Rowley Replied
Thanks Robert

So doing that results in all 500 accounts changing to language EN_GB but not change in the way the date displays. However if I change the user to any other language and then back to EN_GB then that resolves the problem.

How can I force every account to apply this without having to work through each one individually?

Cheers

Trevor
0
Matthew Hall Replied
6948 still doesn't work
Matthew Hall
System Administrator
Farrell Heyworth
0
Trevor Rowley Replied
I have the same issue still. It actually works if you change the language so something else, save the change and then revert to en_GB. However the change doesn't survive a logout!

I've opened a support ticket so will update this thread once a solution is found.

Trevor
0
Trevor Rowley Replied
I'm pleased to confirm that the new build released yesterday (6964) has finally solved this problem.

I have also established that by removing all files except for en-Gb.json from the MRS\App_Data\Translations folder, everyone will have the correct language when they login. That's assuming you only want UK English of course. I also had to remove the en_GB.json file which was created as suggested by Robert Emmett in this thread on 17 Jan.

Trevor

Reply to Thread