Can’t receive emails from same server SMTP
Problem reported by Steve Guluk - December 4, 2017 at 9:19 AM
Submitted
Hello, 
Spent hours trying to make a new server (Windows 2016) work with SmarterMail 16 after migrating from our old server that ran SmarterMail 15 (both Enterprise).
 
Basic email works well. And version 16 seems to be a good improvement over 15.
 
Our setup is using 2 IP addresses bound to SmarterMail (***.96 and ***.100)
Server internal SMTP as administrated via IIS6 uses it’s own IP (***.111) and we don’t require any authentication so that multiple internal Domains can send PHP form generated emails. Our Firewall blocks access to the SMTP server so we don’t have an open Relay. We also don’t receive on the internal SMTP, just sending.
 
Using the exact same settings on the old server we had no problems.
Internal SMTP uses it’w own IP and sends on port 30 to keep it apart from Smartermail.
 
On the new server it worked fine until migrating and turning on SmarterMail.
Now we can only send emails to outside accounts via the internal SMTP server.
For instance, emails sent from a PHP form (php ini references sending on port 30) to an outside gmail account deliver just fine. Accounts on the SmarterMail email server fail with the following errors:
 
 
_______________________________________________________________________
 
--9B095B5ADSN=_01D36CD17FCC324100000009mail2.sgdesign.t
Content-Type: text/plain; charset=unicode-1-1-utf-7
 
This is an automatically generated Delivery Status Notification.
 
Delivery to the following recipients failed.
 
       steve@sgdesign.net
 
--9B095B5ADSN=_01D36CD17FCC324100000009mail2.sgdesign.t
Content-Type: message/delivery-status
 
Reporting-MTA: dns;mail2.sgdesign.tv
Received-From-MTA: dns;905042-app3
Arrival-Date: Mon, 4 Dec 2017 07:56:09 -0800
 
Final-Recipient: rfc822;steve@sgdesign.net
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;550 Authentication is required for relay
 
--9B095B5ADSN=_01D36CD17FCC324100000009mail2.sgdesign.t
Content-Type: message/rfc822
 
Received: from 905042-app3 ([192.168.100.111]) by mail2.sgdesign.tv with Microsoft SMTPSVC(10.0.14393.0);
     Mon, 4 Dec 2017 07:56:09 -0800
 
 
_______________________________________________________________________
 
--9B095B5ADSN=_01D36CC5F7370EFE00000001mail2.sgdesign.t
Content-Type: text/plain; charset=unicode-1-1-utf-7
 
This is an automatically generated Delivery Status Notification.
 
Delivery to the following recipients failed.
 
       Support@sgdesign.com
 
--9B095B5ADSN=_01D36CC5F7370EFE00000001mail2.sgdesign.t
Content-Type: message/delivery-status
 
Reporting-MTA: dns;mail2.sgdesign.tv
Received-From-MTA: dns;905042-app3
Arrival-Date: Sun, 3 Dec 2017 22:50:23 -0800
 
Final-Recipient: rfc822;Support@sgdesign.com
Action: failed
Status: 5.3.5
 
 
--9B095B5ADSN=_01D36CD17FCC324100000005mail2.sgdesign.t
Content-Type: text/plain; charset=unicode-1-1-utf-7
 
This is an automatically generated Delivery Status Notification.
 
Delivery to the following recipients failed.
 
       steve@sgdesign.com
 
 
 
_______________________________________________________________________
 
 
--9B095B5ADSN=_01D36CD17FCC324100000005mail2.sgdesign.t
Content-Type: message/delivery-status
 
Reporting-MTA: dns;mail2.sgdesign.tv
Received-From-MTA: dns;905042-app3
Arrival-Date: Sun, 3 Dec 2017 23:35:16 -0800
 
Final-Recipient: rfc822;steve@sgdesign.com
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;550 Authentication is required for relay

1 Reply

Reply to Thread
0
Even when setting php.ini to use SmarterMail the mails are still routed through the Servers default SMTP service. 
The settings in php as learned here:
https://portal.smartertools.com/community/a88188/smartermail-with-plesk-php-mailer-php-mail-configuration-help-needed.aspx
Create beautiful log events looking like everything is properly being constructed BUT it still uses the default SMTP service rather than the directed php.ini setting that tells it to use mail.sgdesign.net
 
:-(

Reply to Thread