Need help on the SMTP protocol.
Question asked by Char Lee Yeong - November 6, 2017 at 3:58 AM
Unanswered
Hi, 
 
I have issue with my Smartermail 15.7.6443 communication with a Merak according to the log.
I notice that the Smartermail will sent multiple EHLO command because it do not recognize the Ready to start TLS(in bold)?
May I know what is the possible issue and how to address this?
 
2017.11.06] 16:17:53 [10953] Sending remote mail for wxng@infinity.com.my
[2017.11.06] 16:17:53 [10953] Spam check results: [_CUSTOMRULES: ], [_INTERNALSPAMASSASSIN: 5:8], [_BAYESIANFILTERING: passed]
[2017.11.06] 16:17:53 [10953] Initiating connection to 112.199.115.150
[2017.11.06] 16:17:53 [10953] Connecting to 112.199.115.150:25 (Id: 1)
[2017.11.06] 16:17:53 [10953] Connection to 112.199.115.150:25 from 10.6.31.103:64993 succeeded (Id: 1)
[2017.11.06] 16:17:53 [10953] RSP: 220 cyruslogistics.com ESMTP Merak 7.6.4; Mon, 06 Nov 2017 16:17:53 +0800
[2017.11.06] 16:17:53 [10953] CMD: EHLO mail.infinity.com.my
[2017.11.06] 16:17:53 [10953] RSP: 250-cyruslogistics.com Hello mail.infinity.com.my [175.144.132.196], pleased to meet you.
[2017.11.06] 16:17:53 [10953] RSP: 250-ENHANCEDSTATUSCODES
[2017.11.06] 16:17:53 [10953] RSP: 250-SIZE
[2017.11.06] 16:17:53 [10953] RSP: 250-EXPN
[2017.11.06] 16:17:53 [10953] RSP: 250-ETRN
[2017.11.06] 16:17:53 [10953] RSP: 250-ATRN
[2017.11.06] 16:17:53 [10953] RSP: 250-DSN
[2017.11.06] 16:17:53 [10953] RSP: 250-CHECKPOINT
[2017.11.06] 16:17:53 [10953] RSP: 250-8BITMIME
[2017.11.06] 16:17:53 [10953] RSP: 250-AUTH CRAM-MD5 DIGEST-MD5 LOGIN PLAIN
[2017.11.06] 16:17:53 [10953] RSP: 250-AUTH=LOGIN
[2017.11.06] 16:17:53 [10953] RSP: 250-STARTTLS
[2017.11.06] 16:17:53 [10953] RSP: 250 HELP
[2017.11.06] 16:17:53 [10953] CMD: STARTTLS
[2017.11.06] 16:17:53 [10953] RSP: 220 2.0.0 Ready to start TLS
[2017.11.06] 16:17:53 [10953] CMD: EHLO mail.infinity.com.my
[2017.11.06] 16:17:54 [10953] RSP: 500 5.5.1 Command unrecognized: ""
[2017.11.06] 16:17:54 [10953] CMD: HELO mail.infinity.com.my
[2017.11.06] 16:18:54 [10953] The smtp session has timed out.

4 Replies

Reply to Thread
0
Hi,
 
Anyone can help to explain why the server send EHLO twice? Having problem sending mail to that domain.
0
Richard Frank Replied
it's normal behaviour, after the starttls command
 
here an succesful example someone sending mail to my mailserver.. receiving
 
[2017.11.09] 10:04:54 [93.93.121.75][21173265] rsp: 220 mail.soko.nl Thu, 09 Nov 2017 09:04:54 +0000 UTC | SMEV
[2017.11.09] 10:04:54 [93.93.121.75][21173265] connected at 9-11-2017 10:04:54
[2017.11.09] 10:04:54 [93.93.121.75][21173265] cmd: EHLO gen1.alkmaar.nl
[2017.11.09] 10:04:54 [93.93.121.75][21173265] rsp: 250-mail.soko.nl Hello [93.93.121.75]250-SIZE 41943040250-AUTH LOGIN CRAM-MD5250-STARTTLS250-8BITMIME250 OK
[2017.11.09] 10:04:54 [93.93.121.75][21173265] cmd: STARTTLS
[2017.11.09] 10:04:54 [93.93.121.75][21173265] rsp: 220 Start TLS negotiation
[2017.11.09] 10:04:54 [93.93.121.75][21173265] cmd: EHLO gen1.alkmaar.nl
[2017.11.09] 10:04:54 [93.93.121.75][21173265] rsp: 250-mail.soko.nl Hello [93.93.121.75]250-SIZE 41943040250-AUTH LOGIN CRAM-MD5250-8BITMIME250 OK
[2017.11.09] 10:04:54 [93.93.121.75][21173265] cmd: MAIL FROM:<> SIZE=4507 BODY=7BIT
[2017.11.09] 10:04:59 [93.93.121.75][21173265] rsp: 250 OK <> Sender ok
[2017.11.09] 10:04:59 [93.93.121.75][21173265] cmd: RCPT TO:<address>
[2017.11.09] 10:04:59 [93.93.121.75][21173265] rsp: 250 OK <address> Recipient ok
[2017.11.09] 10:04:59 [93.93.121.75][21173265] cmd: DATA
[2017.11.09] 10:04:59 [93.93.121.75][21173265] rsp: 354 Start mail input; end with <CRLF>.<CRLF>
[2017.11.09] 10:04:59 [93.93.121.75][21173265] rsp: 250 OK
[2017.11.09] 10:04:59 [93.93.121.75][21173265] Data transfer succeeded, writing mail to 18130235.eml
[2017.11.09] 10:04:59 [93.93.121.75][21173265] cmd: QUIT
[2017.11.09] 10:04:59 [93.93.121.75][21173265] rsp: 221 Service closing transmission channel
[2017.11.09] 10:04:59 [93.93.121.75][21173265] disconnected at 9-11-2017 10:04:59
0
This means there is issue with the recipient's email server?
 
I did check other delivery, it also send 2 EHLO but the server did not response command unrecognized.
0
Richard Frank Replied
first connection is plain text.. ehlo bla bla
then some commands that are support.. and also lets talk tls?
yes..
then there is a new tls session and that also starts with ehlo bla bla
hmm.. no response.. 
lets try helo bla bla
 
But the other server doesn't respond
 
I can't tell which server is ignoring the other, but sending ehlo after tls session is started is normal.
maybe the merak server does answer and your server doesn't 'hear' it?

Reply to Thread