"The resource cannot be found"
Problem reported by James Jenkins - November 4, 2017 at 9:23 AM
Submitted
Hello,
 
With SmarterTrack Version 13.0.6514.27391, when trying to add an event action, I'm immediately brought to the following error message. Is this a known issue? I can confirm that "/Management/Settings/Modals/frmEventAction.aspx" doesn't exist but "/Management/Settings/Modals" does. But I'm not sure if its the same file. Thanks!
 

Server Error in '/' Application.


The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /Management/Settings/Modals/frmEventAction.aspx

 
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.2106.0

13 Replies

Reply to Thread
0
Michael Woffenden Replied
James - For what it's worth, I cannot duplicate this with my self hosted installation (same version as yours). Looks like this might be specific to your installation. Have you tried re-installing?

Michael Woffenden, Founder and President, Information Results Corporation

SmarterTrack licensee since 2008

0
James Jenkins Replied
I had uninstalled the beta and installed the latest release. I haven't tried a second time but could give it another go.
0
James Jenkins Replied
I've just reinstalled with the exact same results.
0
Derek Curtis Replied
Employee Post
Hi, James. What are the exact settings you're using for your Event? (Type, Conditions, Action(s) you're adding...)
 
Thanks. 
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
James Jenkins Replied
Hi Derek,

When creating the event, I chose:
Category = Tickets
Type = Ticket Created

Once created, I chose to edit the Event, clicked on the Actions" tab, and then "Add Action". I was immediately brought to the error. Everything else was left at default.
0
James Jenkins Replied
I tried uploading a screenshot of the conditions but I get an error of "Your account does not have permission to use hyperlinks in posts." If I add the image inline, it will be too large.

But as I said, they are the default conditions applied after the new event is created.
0
James Jenkins Replied
On a different web server, I had version 13.0.6474.20156. Creating this event wasn't an issue.
 
I then upgraded to version 13.0.6514.27391. Creating this event was still not an issue.
 
Finally, I navigated to "C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\Management\Settings\Modals". This directory was full of aspx files including the missing "fromEventAction.aspx" file.
 
I can try reinstalling again but if this doesn't extract the missing data, should I just manually replace the files in the Modals folder, from the working (good) webserver?
0
James Jenkins Replied
Here are screenshots of the event, conditions and server error..
0
James Jenkins Replied
I'm able to confirm that frmEventAction.aspx does exist in MRS/Management/Settings/Modals
0
James Jenkins Replied
If I use the default Smartertrack install, which is a different IIS application using port 9996, this works. Switching back to the Default Site on port 80 fails. Both the Smartertrack application on port 9996, and the Default Website with the manually added application(MRS Path), use the "SmarterTrack" Application Pool. I can't see any other setting differences.
 
I think I'll completely uninstall, remove Application Pools, and try again.
0
James Jenkins Replied
So as I said, this works when I create a brand new site, not if I add it as an application to an existing site.
 
I also do not get this error with SmarterTrack 12. I even built a brand new Server 2016 system and installed SmarterTrack 12 as an application to a new site.
 
For now, I'll have to rollback to SmarterTrack 12. I need Smartertrack to work as an application to an existing site, to avoid building a new site with binding port number.
0
James Jenkins Replied
I did one last test. I installed SmarterTrack 12.6.6480 as an application to an existing site and do not get "The resource cannot be found" error. I then upgraded to SmarterTrack 13.0.6534 using both the Installer and the zip file. In both scenario's, I ended up with"The resource cannot be found" error.
 
Can Smartertools share some info on this? This bug can be seen by installing SmarterTrack as an application to a new or existing site (right click the site and choose "Add Application..."), and then adding an action to an event.
0
Derek Curtis Replied
Employee Post
James, I started a ticket with you on this. We'd need a bit more info...
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278

Reply to Thread