Unable to delete a domain
Problem reported by John Marx - September 12, 2017 at 8:22 AM
Being Fixed
A domain was accidentally put in with an ampersand (&) and we can't go in and delete. Can't select the box and choose delete. On v16.2.6442.
 

6 Replies

Reply to Thread
0
Rod Lasky Replied
Employee Post
Hi John.  I'll get this over to the developers to be fixed.
 
In the meantime, you can manually delete this domain using these steps:
  1. Stop the SmarterMail service.
  2. Edit C:\Program files (x86)\SmarterTools\SmarterMail\Service\domainList.xml.
  3. Find and remove the <domain> entry containing the & symbol.  Save and close.
  4. Delete the C:\SmarterMail\Domains\[DOMAIN] containing the & symbol.
  5. Restart the SmarterMail service.
 
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
I just wanted to say as of v16.3.6467 this is still an issue.
0
I know in the notes this is marked as fixed for v16.3.6474. It is NOT fixed. I have a domain and checked the box and clicked delete and the toast message said "Cannot read property 'indexOf' of undefined" still. I also tried to click and go into the domain and delete that way and still have the issue. This is the latest SmarterMail v16.3.6474.
0
As a side note to this users shouldn't be able to create domains with bad characters in it. I know the person that did this for us is new but the system should know what is and isn't allowed.
0
Just installed v16.3.6508 and deleting a domain is still not possible that has an ampersand. I see in the logs that you added more logging. If I can send any logs to help with this let me know.
2
Still an issue of not being able to delete a domain. Being that you were just in the code to add a count for domains I would've expected this to be there. Can we get this fixed (no I don't want to manually go into the file system and fix).

Reply to Thread