Smartermail accept any email with Invalid Catch-All configuration (SM Version 15.7.6411)
Problem reported by CLEBER SAAD - August 23, 2017 at 6:20 AM
Submitted
Hello,
I found a bug in Catch-All configuration. I have a domain that configured the Catch-All to an Alias. After that, delete the Alias and Smartermail continue to received messages. When try to delivery to the alias that doesn't exists make bounce. This can be considered a backscatterer problem.
 
To simulate:
1) create a domain;
2) create an alias;
3) configure the domain catch-all to this alias;
4) remove the alias;
5) don't set again the catch-all to none (don't change the configuration).
 
If you try to send any email to invalid address for this domain Smartermail received that with no problem and make a bounce after in delivery process.
 
 

4 Replies

Reply to Thread
0
Rod Lasky Replied
Employee Post
Hi Cleber.  I just tried this on my SmarterMail 15.7.6411, and I did not see this behavior.  Once the Alias was removed, I got an expected "No such user" message when trying to send to this catch-all again.  For further assistance, I would recommend opening up a support ticket.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
CLEBER SAAD Replied
Hello Rod,
Try to do this using webserivces (delete the alias). And try to send to any address (because the catch-all it's active even the alias don't exists).
0
Rod Lasky Replied
Employee Post
Hi Celeb. I just deleted my Alias via webservices, and afterwards I'm still not able to send to my catch-all any longer.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
CLEBER SAAD Replied
Rod I'll open a support ticket (and pay) because I guess that my version 15.7.6411 it's not the same of yours.

Reply to Thread