Gmail migration being blocked by Google? (SM Enterprise 15.6.6347)
Problem reported by W. Troy Leaver - July 28, 2017 at 12:43 PM
Submitted
So a client contacted me today and said when he attempts to migrate from gmail, the test connection button fails, once he's authorized everything.
 
I tested myself, and sure enough the same thing happened to me. I received an email in my gmail inbox from google stating the following:
 
----------
 
Hi Troy,

Google just blocked someone from signing into your Google Account [redacted]@gmail.com from an app that may put your account at risk.

Less secure app
Friday, July 28, 2017 5:28 PM (GMT)
 
Don't recognize this activity?
If you didn't recently receive an error while trying to access a Google service, like Gmail, from a non-Google application, someone may have your password.
 
SECURE YOUR ACCOUNT
 
Are you the one who tried signing in?
Google will continue to block sign-in attempts from the app you're using because it has known security problems or is out of date. You can continue to use this app by allowing access to less secure apps, but this may leave your account vulnerable.
 
----------
 
I know there is an update to version 15, but the release notes don't mention anything about gmail or migration.
 
Any thoughts on what is causing this?

8 Replies

Reply to Thread
0
W. Troy Leaver Replied
Hmm, just noticed the "You can continue to use this app by allowing access to less secure apps, but this may leave your account vulnerable." line in the message. I guess there must be a setting I can use to work around this. I'll leave the discussion in case anyone gets tripped up by this.
0
W. Troy Leaver Replied
And the page with the details on allowing less secure apps:

https://support.google.com/accounts/answer/6010255?hl=en
0
Derek Curtis Replied
Employee Post
Yeah, the mis-named (in my humble opinion) "less secure apps" gotcha. Glad you were able to figure it out. I'm going to mark this as "Resolved" since you posted the link to how to enable the setting.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
W. Troy Leaver Replied
Can we open this back up? I didn't actually test enabling the less secure apps option the first go-round. My client said he couldn't get the mailbox to migrate even after enabling it, and I have confirmed the same for myself.
0
Derek Curtis Replied
Employee Post
Troy,
 
What error are they getting? IS it the same as what you initially posted? Are you sure they're enabling the setting? 
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
W. Troy Leaver Replied
I actually tested it myself after the client reported it still didn't work, and it wouldn't work for me either. I know the credentials are correct because I get the email from Google warning that someone has my credentials, and I've double-checked again and the less secure apps option is definitely enabled.
0
W. Troy Leaver Replied
I also just now accessed the apps with access to google page, deleted the SmarterMail access and permissions, and went through the process from scratch again. Still no luck.
0
Derek Curtis Replied
Employee Post
Troy, I just tried this on our test server, running 15.7.6411. I had to enable less secure apps, but after that, I was able to migrate over 5000 emails just fine. No errors. I'm afraid I'm out of suggestions..apart from possibly opening a support ticket.

As an aside, I know we're on a newer version but we haven't touched mailbox migration in 15.x since January...However, maybe you can try upgrading to see if something, somewhere, fixed the problem?
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278

Reply to Thread