MSPControl and SmarterMail v16
Question asked by Scarab - July 15, 2017 at 10:35 AM
Unanswered
Information if you are using MSPControl and SmarterMail v16...in hopes that this may help someone else and save them the troubleshooting effort to resolve. They do work together using SmarterMail's Legacy API but you will get an error if you are using the Enterprise edition of SmarterMail with a SSL Certificate.
 
To resolve this:
 
1.  Do not use a "Force HTTPS" rewrite rule in the global IIS web.config or in the web.config for SmarterMail. Use the SETTINGS > GENERAL SETTINGS > FORCE WEBMAIL TO USE HTTPS in SmarterMail version 16 only! Otherwise you will receive the following error: "The underlying connection was closed: An unexpected error occurred on a send. —> Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. —> An existing connection was forcibly closed by the remote host"
 
2.  Make sure that in MSPControl that you have the SmarterMail Web Services URL set to HTTP://fqdn.tld/Services. It will no longer work with HTTPS:// as it will result in the same error as #1 (This has been reported to MSPControl as a Bug)
 
3.  Lastly, as passwords are now Salted in more recent versions of MSPControl you must re-enter your Current Admin Password for the SmarterMail service under SETTINGS > SERVERS > %SERVERNAME% > SMARTERMAIL and re-save your SmarterMail Settings in MSPControl. Otherwise you will get the following error: "The request failed with HTTP status 403: Forbidden."
 
These three steps will ensure that both programs will continue to play nice with one another.

Reply to Thread