Can't access log folder in SM 16
Problem reported by ellisfr - May 29, 2017 at 3:11 PM
Submitted
On my new SM 16.0.6355 installation (Windows 2016 Server Essentials), I wasn't able to access the logs folder in the admin.
 
It was an error message from IIS, so I had to add IIS_IUSRS in the permission of the C:\SmarterMail\Logs folder.
 
I don't know if this is normal or if this is a missing permission setting in the installer.
 

10 Replies

Reply to Thread
0
Ronald Raley Replied
Same issue we have. I have not added the permission manually yet.
0
Matthew Shepard Replied
I had the same issue and doing what you suggested: adding that user with only read permission fixed it for me; Thank you very much!
0
Tony Loosle Replied
Thanks!!
0
Falk Brockerhoff Replied
Hello all together,
 
since upgrading to SM 16 we have also problems to view the logs:
 
 
 Adding the User IIS_IUSRS to the share didn't work for us.
 
I think the solution adding IIS_IUSRS to in the permission didn't work for us, is because we are using a network share. When I add IIS_IUSRS to the share it is the user of the computer "stor00". This is the server which provides the share, not the user of the server which has the share mounted:
 
0
Matthew Shepard Replied
You could try adding the computer smartermail is installed on instead of a user. I think adding the computer makes it so all local users to the computer falls under the same rights. Or maybe see if you can specify the user directly with nameofsmartermailserver\IIS_IUSRS Not sure if the file share server will be able to recognize that as a valid user though.
0
Falk Brockerhoff Replied
Hello Metthew. As far as I know it is only possible to set an other computer to the permissions, if they are in the same domain. Unfortunatly we do not use a DC for this setup. Both servers are only in the same workgroup. Please correct me if I'm wrong.
0
Matthew Shepard Replied
I think you are correct, the one computer has no way of seeing the other one then. Though I have no experience with work groups, they might be able to see other users. I keep running through possibilities in my head and they all have to do with one computer being able to see the users on the other (like changing the iis service to run as the user you used to map the network share) and I can't think of a way to get this to work at the moment if the computers can't see each other's users. sorry.
0
Matthew Shepard Replied
You could look at moving only the logs from that network share to the local computer that smartermail is installed on. You can specify the location for the logs under the admin login to the server-> manage-> troubleshooting-> and the options tab.
0
Falk Brockerhoff Replied
Your last proposal is that what I'll do. I hope just temporarily till someone of the SmarterMail team maybe find a solution. Thank you for your thoughts and assistance, Matthew!
0
Falk Brockerhoff Replied
Changing the location from the network share to a local partition makes the error disappear. Even without the IIS_USERS permission. Nevertheless it would be great if SmarterTool would take a look at this. After all it worked fine in SmarterMail 15.

Reply to Thread