What are the steps for moving from Smartermail 16 back to 15?
Question asked by Jerry Jacobs - May 24, 2017 at 1:42 PM
Answered
Needs some work before it'll work for my group.   Many are disappointed and asking to move back.

20 Replies

Reply to Thread
0
Tim Uzzanti Replied
Employee Post
Significant changes and modifications are made to data files on major versions.  You would need to do a restore.
 
Out of curiosity, what are they disappointed about?
 
Tim
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gary Pacitti Replied
Tim does this mean there is no rollback ? Can you clarify what you mean by a restore ? Doesn't that mean email will be lost ?

We are holding off upgrading, because we can't afford to be in a position as the original poster now finds himself - sadly
0
Tim Uzzanti Replied
Employee Post
Yea, if you ran SM 16.x for days and wanted to restore your server from backups.

This was the first comment we have seen related to SM 16.x and why I'm asking for more information.

We have been doing a soft rollout in an effort to manage the release and the speed of upgrades for 15 million users.. As you probably noticed, we haven't sent any emails out regarding the public availability of SM 16.x.

But, people are finding out we released and upgrading quickly with the number of active domains and users growing rapidly.

Things have been really smooth and were going to continue releasing versions each week for the next couple weeks tackling little issues and then will be going into a 16.1, 16.2 cycle!

Tim
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Joe Wolf Replied
We rolled back to 15.x. Too many complaints on how slow it was. Calendar hours do not allow to be closed on any day. Number of messages not showing per mailbox. Just too many complaints.

16.x was at least 50% slower on the webmail performance for us. The SMTP, POP, and IMAP were faster.

Also the login to the webmail was changed so anyone saving their password in a browser lost their login. And of course most users don't know their password.

Just too many negative things to deal with.

Upon rollback the only file we had to restore was the mailconfig.xml The rest worked fine after removing 16.x and installing 15.x.
0
Jerry Jacobs Replied
Used on Win 10 v1703
default browser - IE v11.296.15063.0 (other applications require this) 
Most in our group use the webmail interface exclusivily, so all of the following are experienced in that interface.
-These issues exist in IE and most are not an issue in Chrome and Firefox.  They are also not an issue in an external win10 v1607 machine.
--Hyperlinks in mail do not work
--cannot open a new email using a group out of contacts (related to the next issue)
--Popups do not work...even if the popup blocker is turned off in IE
--May be other issues I'm not aware of
--We finally told the group to only use Chrome..which is a problem since our default app needs to stay set to IE
These were issues/lost features reported back to me from the group when using webmail in Chrome and IE
--Can't use the "To" in a new email to select an email send to group.  Alot of frustration with this.
--When sending with a group, the user has to go thru an excessive number steps to select and send the email...awkward-less than intiutive
--The ability to use checkboxes is gone - slows down selecting mail to be deleted (shift and click selects a range, but not individual mail as you scroll down)
--No abiity to select preview pane options - on-off, right-bottom
--Some complaints about the notifications not being the same...but this is most likely a Win10 config/user just doesn't like change issue
Overall like the look and feel, but the complaints are coming from qualified users; all about functionallity.   
Would the following be acceptable restoration steps?
1) Confirm a current backup is in place
2) Uninstall v16
3) Restart server
4) Stop IIS
5) Restore most recent v15 backup folders/files with the exception of Data
6) Install most recent v15
7) Restart IIS
8) Confirm functionality of application and data
0
echoDreamz Replied
Yeah - We are receiving a dozen or more complaints a day about the webmail interface being slow. The SmarterMail main process is using about double the CPU resources that it used to use. Eating more RAM as well.

The spool page will say "12" spool. but only 3 emails listed. The spool count will continue to change, but the listed emails in spool never updates. Ever. I left it open for several hours, came back, same emails in spool from when I left it.

We have customers who are complaining that leaving the SM interface open in their browser overnight causes it to become unresponsive or slow. I've seen this as well just trying to load the spool with several hundred emails in it. SM 15 even with several thousand emails in spool, it loaded instantly. SM 16 is churning its wheels while chrome is crying a slow death.

The browser notifications are a great step, but lack of supporting folders seems like a major oversight, especially in today's world where nearly all of our users (if not all of them) use folders with content filter rules to move emails automatically.

The login issue has happened to us as well, many upset customers who got into their office on Monday and.... omg, what is my username / password!?!

Lots of complaints about the interface not loading on iOS, though that seems to be hit / miss.

By a mile, the biggest complaint we are receiving continuously is about the interface and how "bad" it is in terms of appearance. What I am hoping for is that maybe, just maybe... SM 16 can support multiple "themes" and we can get a SM 15 look-n-feel theme for SM 16 :).

Would also love to disable the backgrounds on login, I've set SmarterMail to use a solid color, but it continues to show the background images. A few of our bigger business customers (an airline) felt it was a bit much and unprofessional looking. This of course will vary.

Christopher

0
Derek Curtis Replied
Employee Post
The web interface in 16.x is faster than previous versions for a few reasons. Most notably, we're using the API completely so 16.x is a single page app based around the latest web technologies like Angular and SignalR. Therefore, while on an initial request there IS some front-loading that occurs, all other requests receive only the info that's needed, the rest is cached. Previous versions of SmarterMail loaded everything, on every page, on every request. 

As for the other issues, as I think Tim's mentioned, we'll be putting out weekly builds for a bit, then start moving to .1 and .2 builds. This week's release will take care of some of the other issues like the login page backgrounds not saving properly. In addition, themes are there and more are coming, plus you will be able to fully edit the CSS to suit your needs, and that file will NOT need to be saved/restored on upgrades. 
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Christopher Hiatt Replied
My users are also commenting on how slow the web interface is. I know there is supposed to be an initial page load with some items cached but it just isn't as snappy as V15 was by a decent margin.

Quick testing from Galaxy Note 5 with chrome on wifi. Same LAN as server.
V15 loads login page near instantly. Reloads near instantly.
V16 loads on first visit in 7-15 seconds. Reloading the same page still takes 1-2 seconds.
0
echoDreamz Replied
I understand that the interface is supposed to be faster, but clearly something is up. Not just our users, but even customers here are complaining. The interface may request smaller amounts of files, but clearly something is causing the interface to be heavier as we are receiving complaints from customers who have never contacted us previously. We've noted that the SM process as well as the IIS worker process CPU usage as well as RAM usage have gone up pretty considerably.

Christopher

0
echoDreamz Replied
More example, before our upgrade to SM 16, our MailService.exe maxed at 8189MB of RAM as the highest usage. The highest SM16 has reached is 11516MB, so around 3.3GB more RAM usage. avg. CPU has also gone up about 20-30%.

The IIS worker process for SmarterMail has also gone from a max of 1279MB to 1615MB so far. Clearly something has increased resource usage. I assume the IIS stuff is possibly due to some caching which is fine. Just more concerned with the massive jump in CPU / RAM usage of the main process.

Christopher

0
Tim Uzzanti Replied
Employee Post
You should start a ticket with support. Strange issues. Possibly missing some files on install.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Tim Uzzanti Replied
Employee Post Marked As Answer
We will be happy to open some outbound support incidents and take a look at some servers to evaluate.  We have all historical stat information on CPU, Memory, Disk I/O and can verify utilization before and after the upgrade.
 
Keep in mind right after the upgrade SM 16.x does update accounts to new data formats etc.  It does this in the backgrounds and prioritizes accounts based on usage etc.  Depending on how many users you have is how long this takes.  
 
Also, we can evaluate the speed of the web interface on your installations etc.
 
For shits and giggles I have asked for a couple new test environments setup for 15.x and 16.x to compared speed under significant load and large mailboxes etc.  We have done this numerous times and will evaluate again.
 
If you are interested in us taking a look at your install, please let us know.
 
Tim
 
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Derek Curtis Replied
Employee Post
Jerry, regarding this one:

--Popups do not work...even if the popup blocker is turned off in IE

Do you get a DNS issue when you try opening a pop up? If so, that's a known issue and is resolved in the build out tomorrow. (Friday, 5/26)
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Rod Lasky Replied
Employee Post
Hi Jerry. I've tested your IE 11 issues against our minor release coming out tomorrow. Pop-ups are working for me. Hyperlinks are also working, however I've reproduced one scenario where they're not. That's only when I create a hyperlink, and don't specify to open in a new tab. I'll get that fix into our next minor release.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Jerry Jacobs Replied
Derek - Rod - Nope - no DNS issues - This occurs when attempting to send an email from contacts using a group. Has happened internally on our win10 1703 most recent IE Patch and externally on a win10 1607 with KB3203621. Hyperlinks fail in emails within 1703 and work in the external 1607. I'm wondering if IE patches are now specific to win10 ver since the 1607 auto updates and doesn't have the newer patch used in the 1703
0
Derek Curtis Replied
Employee Post
Jerry..got it. Just to be clear: when you select multiple contacts and use the Send Email action, nothing happens? If so, I was able to replicate it on my laptop...
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Jerry Jacobs Replied
Derek, With regards to multiple contacts and sen email action - yes that is correct.
We've determined the link problem in the emails (when using IE) is related to having protected mode enabled. When it's disabled the links work.
0
Derek Curtis Replied
Employee Post
Jerry..okay, glad I could replicate it. It's been added to the list for fixing in next week's release. As for links, protected mode has a ton of restrictions, so I suppose it makes sense that that was blocking the links. (I haven't seen that in any browser.) IE 11 is difficult enough to support along with Edge and all the other latest browsers. Adding restricted mode to the mix makes it even more difficult. So we don't recommend it, nor can we support it. May be worthwhile to add the SmarterMail site as a Trusted site as I think that will bypass protected mode...I think. :)
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Jerry Jacobs Replied
We've decided to leave the v16 installation in place, but are setting users to use Chrome or FF. Too many issues with IE. That being said, once you have email action issue above resolved, I think it will work fine with some tweaks.

We had SM in trusted, but protected mode was enabled in that zone also. It's certainly less riskier disabling here than in the internet zone.
0
Jerry Jacobs Replied
Would be nice to call a contact group directly from the "To:" area on a new email by just typing the group/category name in.

Reply to Thread