Cyren ran into an error scanning a message.
Problem reported by Mike Schürmann - May 11, 2017 at 5:43 AM
Resolved
Hi,
 
i´m using smartermail enterprise edition 15.5.6222 with cyren-antispam.
 
Since some days, every mail will stay some minutes in the spool with the status "spam-check", after that it will be delivered.
 
In the delivery logfile i found the following - for every mail:
 
07:20:59 Cyren ran into an error scanning a message.
07:20:59 [24808] Unable to run Commtouch check: Exception while processing message: 24808, Exception: Object reference not set to an instance of an object.
Stack Trace:    at Commtouch.CommtouchClientInterface.ProcessMessage(String messagePath, String senderAddress, String senderIP, String[] localRecipients, String[] remoteRecipients, CommtouchSettings commtouchSettings)
   at CyrenClient.Program.StartScanMessage(String data)
07:20:59 [24808] Spam check results: [_SPF: None], [FIVE-TEN: passed], [HOSTKARMA - BLACKLIST: passed], [HOSTKARMA - BROWNLIST: passed], [HOSTKARMA - WHITELIST: passed], [NIX SPAM: passed], [SORBS - ABUSE: passed], [SORBS - DYNAMIC IP: passed], [SORBS - PROXY: passed], [SORBS - SOCKS: passed], [SPAMCOP: passed], [SPAMHAUS - PBL: passed], [SPAMHAUS - PBL2: passed], [SPAMHAUS - SBL: passed], [SPAMHAUS - XBL: passed], [SPAMHAUS - XBL2: passed], [_REVERSEDNSLOOKUP: passed], [_BAYESIANFILTERING: failed], [_COMMTOUCH: 0,Nonspam], [_INTERNALSPAMASSASSIN: 0:0], [_DK: None], [_DKIM: None]
07:21:02 [25783] Delivery started for  at 07:21:02
07:21:03 Restarting Cyren. Too many errors have occured so far.
07:21:03 Restarting Cyren. Too many errors have occured so far.
 
The process "CyrenClient" seems to do something... but what?
h t t p s://nextcloud.rackspeed.de/index.php/s/yrXuRdBN7P0WTo7
 
Restarting the spool, smartermail or the whole server won´t fix this problem.
Only if I disable cyren anti-spam in the spam-setting AND restart the whole server, will fix the problem and mails will be delivered after seconds.
 
Regards
Mike

5 Replies

Reply to Thread
0
Robert S. Randazzo Replied
I would like to second this report.  Same issue here, but with SmarterMail 16.x.  We upgraded to latest on Thursday and Cyren has ceased operating effectively, instead reporting an error for each email scanned.
Robert S. Randazzo
PMDG
0
Derek Curtis Replied
Employee Post
Try installing the latest SmarterMail 15.x minor and see if that clears it up: https://www.smartertools.com/smartermail/downloads/15
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Derek Curtis Replied
Employee Post
Robert..we'll have to look into this. We run Cyren ourselves on 16.x and haven't seen this issue.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Matt Petty Replied
Employee Post
Some installs of SmarterMail had the possibility of not working because our installer didn't register the DLL's that the SubProcess (Cyren) uses. Updating to the latest 16 (as of Friday) should fix this.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Robert S. Randazzo Replied
Matt,

Thank you- this did indeed resolve the issue for us. I very much appreciate the quick service.

Robert S. Randazzo
PMDG

Reply to Thread