Cyren Antivirus does not appear to be working
Problem reported by Micky Witztum - January 26, 2017 at 8:09 PM
Known
I have licensed the product, but the Cyren specific reporting shows NO results at all.  I would expect that messages passing thru the scanner would show up on the table under "Non-Virus Result" in the built in report, right?
 
I know that mail has passed thru the system and is being looked at by ClamAV, but I cant find any way to validate that Cyren is even functioning.
 
Is there a Cyren log anywhere?  Is there any other log to review?
 
Any help would be appreciated.
 

5 Replies

Reply to Thread
0
Rod Lasky Replied
Employee Post
Hi Micky.  Even though Cyren is licensed, make sure you have it enabled for filtering in Security >> Antispam Administration.
Afterwards, you should be able to search your delivery logs for:  [_COMMTOUCH: 
 
 
 
 
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Micky Witztum Replied
Rod, Yep I did!  I just checked the logs and see an error clearly now. Another part of this is that I do also see Cyren referenced in the mail header as I enabled the Cyren Anti-Spam service on a trial basis as well.  That does appear to be working.
e.g. one email had this line in the header:

"X-SmarterMail-Spam: Commtouch 0 [value: Nonspam], SPF_Pass, DK_None, DKIM_Pass"
 
Following is a set of log entries...and note the error message:

[2017.01.27] 00:02:28 [79404] Unable to run Commtouch check: System.Runtime.InteropServices.COMException (0x80041001): Unable to comply with the request because you are not licensed for the antispam service. Contact your service provider to enable the service.
[2017.01.27]    at Commtouch.CommtouchClientInterface.ProcessMessage(String messagePath, String senderAddress, String senderIP, String[] localRecipients, String[] remoteRecipients, CommtouchSettings commtouchSettings)
 
No such error on the spam check...
 
[2017.01.27] 00:02:28 [79404] Spam check results: [_REVERSEDNSLOOKUP: passed], [_BAYESIANFILTERING: passed], [_COMMTOUCH: 0,Nonspam], [_INTERNALSPAMASSASSIN: 0:0], [_SPF: Fail], [_DK: None], [_DKIM: None],..."  ...more tests listed, but omitted here.
 
This error seems right as I am not seeing any evidence in the report that should track the Cyren Anti-Virus activity.  The report listed under the "Spam and Virus Reports" called "Cyren Zero-hour Antivirus (formerly Commtouch)" has a grid that shows the results.  All of the columns show "0" for all dates including the "Non-Result" and "Unknown Result" columns.
 
I have rebooted my server more than once while working on this.  This is a freshly installed SM Version 15.5.6222 system on a new Win 2008r2 VM that I just built this week.  I installed the product and then migrated my XML, Dat and data files from an older Win 2008 server which hosted SM for some years.  Everything is running pretty well now... other than this.
 
I did have several problems getting ClamAV and ClamSup running by the way, as the VS C++ 2010 libraries (both 32 and 64 bit) were not installed by the SmarterMail installer on a freshly installed OS.  See this thread for more info...and I posted my results there as well.

See thread titled "ClamSup default install" originally posted 9/9/16
 
Tried to post the hyperlink to the thread...but got an error that said I can't "use hyperlinks in posts."  Is this something I can get approved for?
 
In any case, any help you or others can provide would be great!
Thanks!
1
Matt Petty Replied
Employee Post
Hello,
 
We are experiencing issues with some trial license keys for the antispam module on Cyren. This is not an issue with your environment. We are in talks back and forth with Cyren right now on resolving them. I can keep you updated here. You don't really need to make a ticket as we already have a ticket we are following that has this exact issue. 
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Rod Lasky Replied
Employee Post
Micky. How long ago did you start the trial? It typically takes 24 hours for Cyren to start working after enabling.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Micky Witztum Replied
Matt,

As you pointed out, the trial license key that I am using for the Anti-Spam is NOT the issue. In fact, it appears to be working fine on my end.

I purchased the Cyren Anti-Virus license...and it shows as active in my licensing screen. Note this is NOT a trial license at all.

Can you confirm if there are known issues with purchased licenses of Cyren, of any sort?

Reply to Thread