SmarterMail 15.2 does not try secondary MX?
Question asked by Chia Lin Yap - August 14, 2016 at 9:16 PM
Answered
Hi all,
 
I have a SmarterMail 15.2 acting as a SMTP gateway. Recently after upgrading it to 15.2, many users complained of bounced emails. The delivery log as below:
 
[2016.08.12] 11:22:42 [46462] Delivery started for finance@spanlogic.info at 11:22:42 AM
[2016.08.12] 11:22:46 [46462] Skipping spam checks: No local recipients
[2016.08.12] 11:22:49 [46462] Sending remote mail for finance@spanlogic.info
[2016.08.12] 11:22:49 [46462] Initiating connection to 203.115.214.162
[2016.08.12] 11:22:49 [46462] Connecting to 203.115.214.162:25 (Id: 1)
[2016.08.12] 11:22:49 [46462] Binding to local IP 103.51.43.161:0 (Id: 1)
[2016.08.12] 11:22:49 [46462] Connection to 203.115.214.162:25 from 127.0.0.1:60793 succeeded (Id: 1)
[2016.08.12] 11:22:50 [46462] RSP: 421 Cannot connect to SMTP server 203.115.214.162 (203.115.214.162:25), connect error 10061
[2016.08.12] 11:22:50 [46462] CMD: QUIT
...
...
...
[2016.08.12] 17:24:50 [46462] Sending remote mail for finance@spanlogic.info
[2016.08.12] 17:24:50 [46462] Initiating connection to 203.115.214.162
[2016.08.12] 17:24:50 [46462] Connecting to 203.115.214.162:25 (Id: 1)
[2016.08.12] 17:24:50 [46462] Binding to local IP 103.51.43.161:0 (Id: 1)
[2016.08.12] 17:24:50 [46462] Connection to 203.115.214.162:25 from 127.0.0.1:51628 succeeded (Id: 1)
[2016.08.12] 17:24:52 [46462] RSP: 421 Cannot connect to SMTP server 203.115.214.162 (203.115.214.162:25), connect error 10061
[2016.08.12] 17:24:52 [46462] CMD: QUIT
[2016.08.12] 21:24:59 [46462] Sending remote mail for finance@spanlogic.info
[2016.08.12] 21:24:59 [46462] Initiating connection to 203.115.214.162
[2016.08.12] 21:24:59 [46462] Connecting to 203.115.214.162:25 (Id: 1)
[2016.08.12] 21:24:59 [46462] Binding to local IP 103.51.43.161:0 (Id: 1)
[2016.08.12] 21:24:59 [46462] Connection to 203.115.214.162:25 from 127.0.0.1:62921 succeeded (Id: 1)
[2016.08.12] 21:25:00 [46462] RSP: 421 Cannot connect to SMTP server 203.115.214.162 (203.115.214.162:25), connect error 10061
[2016.08.12] 21:25:00 [46462] CMD: QUIT
[2016.08.12] 21:25:05 [46462] Bounce email written to 40453224.eml
[2016.08.12] 21:25:05 [46462] Delivery for finance@spanlogic.info to name-removed@affinhwangam.com has completed (Bounced)
[2016.08.12] 21:25:05 [46462] Delivery finished for finance@spanlogic.info at 9:25:05 PM    [id:40446462]
 
 
I verified that the recipient's MX isn't working. However, the recipient domain has a secondary MX which is working.
 
So I'm wondering, why is SmarterMail not trying secondary MX, primary MX failure? 
 
I have specified 9 retries and all of the retries only targeting the primary MX.
 
Please help, thank you!
 
 
 

14 Replies

Reply to Thread
0
Chia Lin Yap Replied
Has anyone facing the same issue, no? sob sob...
0
Merle Wait Replied
I am not on 15.2, so I can not say..... Haven't experienced that problem... (at least no one has complained...) but have to admit that I am now curious myself.
0
DJ Won Replied
Hi Yap, it look like you have installed anti-virus and have setup filter out going SMTP. Base on your delivery log, your server were succeeded to the 203.115.214.162 SMTP port . I believe is your internal anti-spam software have a SMTP proxy to filter all out going email causing the issue. You could try to disable your SMTP outgoing filtering on your anti-spam software.



[2016.08.12] 21:24:59 [46462] Connection to 203.115.214.162:25 from 127.0.0.1:62921 succeeded (Id: 1)
[2016.08.12] 21:25:00 [46462] RSP: 421 Cannot connect to SMTP server 203.115.214.162 (203.115.214.162:25), connect error 10061
0
DJ Won Replied
I have facing the issue before, and we found this is due to our anti-virus software has filter outgoing SMTP, whether we telnet what IP address X.X.X.X port 25, is able to telnet. After we disable the outgoing SMTP filtering, all is working fine. Smartermail will send to secondary MX record, unless the primary MX is not able to connect port 25.
1
Chia Lin Yap Replied
Hi DJ Won, thank you very much for the pointers.
 
I have checked again, but we really do not have any outgoing filter or anti-virus or anti-spam enabled.
 
If you try to telnet to the primary MX (mx2.affinhwangam.com, mapper.gslb.fedex.com) from other places (like centralops.net), you'll see that the connection to the primary MX timed out. You actually got connected, but it eventually timed out.
 
Smartermail keeps on trying to connect to the primary MX, each time connected successfully, but eventually timed out. 
After the specified number of retries, Smartermail bounced the mail, and never attempted to try any of the secondary MX.
0
DJ Won Replied
Hi Yap,

Did you try to telnet the primary MX mx2.affinhwangam.com(203.115.214.162) SMTP port 25 on your email server? Is it able to telnet in?
0
Chia Lin Yap Replied
Hi DJ Won,
Yes I did try to telnet mx2.affinhwangam.com(203.115.214.162) SMTP port 25 on my email server.
 
It got connected, but no welcome banner or anything, and later timed out.
 
Not only tried to telnet on my own server, I also tried with many other online telnet tools, all timed out.
 
I can safely say that mx2.affinhwangam.com is not working, and I'm afraid this situation is by design, that is they purposely put a broken MX as primary, in order to fight spam.
 
But why SmarterMail won't try the other MX, since the primary MX has timed out?
 
I'm having the same problem with fedex.com as well. SmarterMail keeps on trying to send to primary MX mapper.gslb.fedex.com, which timed out, but never try secondary MX smtp.dmz.fedex.com.
 
 
0
Andrea Rogers Replied
Employee Post Marked As Answer
Hi Chia,
 
Sorry you're having this trouble! I've verified that SmarterMail should be trying the secondary MX records when the primary fails. Since this is not occurring in your installation, I would encourage you to reach out to our Support Department for further review. They will be able to log into your system and determine if this is a bug in the software or an issue specific to your installation. (Please keep in mind that if this issue is caused by a bug, your support ticket will be refunded.)
 
You have support tickets available on your account, so to submit this problem to support, please click on the Tickets button up above. Then click Start Ticket and choose the Support Department. You can also paste a link to this Community thread so they can see what details have been discussed and what you've already attempted to resolve this. 
 
Thank you!

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
DJ Won Replied
Hi Yap,

It look like you have proxy listening port 25 for outgoing traffic. You may try telnet again 203.115.214.162 SMTP 25, and open another terminal run below command to check your process which is listening outgoing SMTP port.

netstat -aon | find ":25"

http://www.howtogeek.com/howto/28609/how-can-i-tell-what-is-listening-on-a-tcpip-port-in-windows/

0
Chia Lin Yap Replied
Hi DJ Won,

Thank you for the pointers.

I have checked netstat and only found MailService.exe listening to port 25.

The thing is, I'm pretty sure the recipient's primary MX is (deliberately) non-functional.

SmarterMail is able to try secondary MX, if the primary MX is totally not reachable.

However, in my case, SmarterMail is not trying secondary MX, when the primary MX is able to be connected, but timed out waiting for welcome banner.
0
Chia Lin Yap Replied
Hi Andrea,

Thank you for the verification. Would you mind helping me to verify one thing again, that is, what constitutes a failure of the primary MX?

I can see that SmarterMail DOES try secondary MX, when the primary MX is not reachable.

But my problem is, if the primary MX is connectable, but timed out waiting for welcome banner or HELO, then SmarterMail doesn't try secondary MX, but keeps on trying to send to primary MX for the configured number of retries.
0
DJ Won Replied
Hi Yap,

Did you check what process is listening when you are telneting 203.115.214.162:25. I means you may telnet 203.115.214.162 port 25 during the time, you open another terminal to process netstat.

Example:
TCP XXX.XXX.XXX.XXX:XXX 203.115.214.16:25 ESTABLISHED XXX
0
Chia Lin Yap Replied
Hi DJ Won,

When I telnet to 203.115.214.162:25, the connection was terminated immediately with a response 421, so netstat comes up nothing.

I found this thread https://portal.smartertools.com/community/a87828/solved-seems-that-smarter-mail-is-no-able-to-send-mail-to-secondary-mx-records.aspx that suggests a reinstall of SmarterMail might fix the problem, will give that a try.

Thank you!
0
Andrea Rogers Replied
Employee Post
I've confirmed with development that SmarterMail should try the secondary MX if delivery to the primary one fails due to a timeout. So there may be something specific to your installation causing this, or it could be a bug in this version of the software. I'd encourage you to allow our Support Department to continue reviewing this by submitting a support ticket.

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

Reply to Thread