Adding Google Drive as Connected Service
Problem reported by kevind - June 14, 2016 at 11:48 AM
Submitted
With 15.1.6005 and Internet Explorer:
  1. Sign into your Google account which is not currently connected to SmarterMail.
  2. Go into SmarterMail Settings -> Connected Services
  3. Try to add your Google Drive
  4. The screen flashes, but you don't see anything because the Google Request for Permission window is hidden by the main window (works fine with Chrome as the window stays on top)
Other things that could be tuned up with this process:
  • for Display Name, default to the Google account instead of "My Google Files" so that a) you can tell the difference when using multiple Google Drives and b) it's more descriptive when you compose message and click Link From.
  • When you provide Google with a name, can you include the user's email address so that when they review connected apps in Google, it says "SmarterMail - joe@example.com" instead of just SmarterMail? Good for when you connect to the same drive from multiple mailboxes.
Thanks,
Kevin

2 Replies

Reply to Thread
1
Rod Lasky Replied
Employee Post
Hi Kevin!   Make sure that you have "Allow Less Secure Apps to Access your Account" enabled.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
kevind Replied
Hi Rod! I don't think it matters whether you allow less secure apps or not -- works the same both ways.

It's really just a matter of which window has the focus. For some reason in IE, the Google window pops up under the SmarterMail window so it's hidden. I added some better instructions to the original post so that you can duplicate.

Reply to Thread