Importing users from CSV doesn't honor user defaults
Problem reported by David - June 10, 2016 at 5:57 AM
Resolved
I've been creating users importing a CSV a lot lately.
There's a problem when you create users this way, the default new user settings are completely skipped - mailbox size, default Inbox view, default services enaled/disabled etc are not copied.
 
Now this is a problem on a server with many users and a lot of additions, one that I can't solve with the user propagation tool - that tool overrides settings for all users, but not all users have same settings so I can't use that as a workaround. Currently, I need to update each user manually and that's painful.
 
Please correct the import procedure so that when it creates a new user, it follows the same user defaults as when you're creating a new user from the web interface.
 

9 Replies

Reply to Thread
0
Eric Tykwinski Replied
I've noticed the same, but it's rather easy to propagate default user settings so I'm not overly concerned. Are you importing batches of new users on an existing domain? IE searching through 1K users for the new 100 that you added would be a pain.
0
David Replied
As I've already mentioned in the 2nd paragraph, I am adding new users and can't effectively use the propagation tool, as for some previously added users I've already changed some settings (mailbox size or webmail preferences, for instance).
But also, having a workaround for this or not is not the point. If we have a template with defaults for new users, then that template should be applied when creating a new user. And currently it is not applied when doing an import using CVS file. This is just a bug that needs fixing, an overlooked part, should be easily fixed.
0
David Replied
To answer your question, I have some 10-20 additions from CSV every now and then, on an existing ~150 users server. Not that big of a problem actually but still annoying to have to go through each of the new users a check/unchek boxes on several tabs. It's more of an annoyance then a problem. But if I had to add 100 users, it would be a really pain in the back.
0
Eric Tykwinski Replied
Apologies, if I offended as that was not my desire. We are mainly hosting other companies, so besides the first import, it's usually the end user administrator adding new users. As I suggested in an enterprise environment where I would be adding/deleting many users, this would definitely be an issue, and I've seen the same issues.
0
David Replied
No no. No offense of kind taken Eric. I apologize if my tone was off, actually.
1
Alex Carnot Replied
Employee Post
This should be fixed in the latest version of SmarterMail 15, Version 15.1.6005. Let me know if the issue is still occurring after updating.
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
C.L. Lee Replied
Seems that the issue came back whereby imported users' settings different compare to the domain/user default.
My current smartermail version 15.3.6109.
 
Could you please assists?
0
Von-Austin See Replied
Employee Post
C.L. I've been able to replicate this same behavior. 
 
I'll bring this back up to our developers to let them know it's still occurring so we may review further. I'll update this thread here shortly after I've met with the SM team. 
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Von-Austin See Replied
Employee Post
C.L.

I reviewed this with our developers, and in my test I was expecting the global values for user defaults to be applied. The developers clarified that this will actually be performed against the domain's user default settings as these are more likely to be a better reflection of what the user settings should actually be.

I have confirmed this was the case in my test environment. Could I have you verify this for me ? Please sign into SmarterMail as the domain administrator and navigate to Settings -> Domain Settings -> Advanced -> User Defaults, you will want to change these values to match the expected values and then perform the re-import on the users from the CSV, the values should then be as expected.
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread