I am close to giving up on smartermail for enterprise clients
Problem reported by Mike Ingram - June 7, 2016 at 10:41 AM
Submitted
I am using smartermail 15 enterprise with all of the most current updates. I am having an error pop up on multiple clients locations, some on domains, some on workgroups, using windows 10 home and pro and using outlook 2013 and outlook 2016. I have a ticket open with smartertools but have not resolved this yet and I am close to giving up. I did dsicover some cert issues maybe and SSL Labs and mxtoolbox give my mail server a pass score etc.Since this is happening across many client locations, it is not a network issue. There must be some weird setting or config with my server that is causing this... not sure. Enterprise customers use Outlook still and I can not ask them to use webmail all day, just won't work for most of them.... This has been happening for weeks and at this point I do not have faith in putting any new customer on my smartermail server and I might switch all my biz clients to hosted exchange.. it just works with outlook.. All client computers and office 2013/16 is updated. I wanted to throw that out there as well. Has anyone seen this error.. can anyone help determine why? I have not been able to narrow down why or when, just when a client hits the send/receive button or types a new email and hits send, this error pops up.. a reboot fixes it for a little while then happens again... some clients it happens every few days. Same error on all clients outlook, except the email address/account of course.
 
Error:
 
Microsoft Outlook
The server configuration prevents you from synchronizing. Contact your system administrator.
 
Account: the email address is here
File: outlook\pstprx\storeas\util\airsyncstatuscodes.h
line: 226
HHTP/1.1 403 Forbidden
SyncStatus: 403
To retry press F9
Error code  0x80004005
 
Again, I can not ask them to move away from Outlook. I am going to switch a few of them off smartermail to hosted exchange this weekend if I can not get a fix. Them slowly stop using smartermail.. This has been a huge drain on time and resources and not worth trying to figure out any more. This is one last ditch effort to get help before I give up! 
 
Thank you very much for reading.
-Mike

7 Replies

Reply to Thread
3
Assin Ontivi Replied
Just when will SmarterTools get this? --- SMARTERMAIL SYNC HAS TO WORK, ALL THE TIME, ON ALL DEVICES, USING ANY PROTOCOL IT CLAIMS TO BE COMPATIBLE WITH. Yes, it is understood that glitches happen, but there are too many sync issues with SmarterMail, too much of the time, as it stands now.
 
If it wants to continue to play in the enterprise, SmarterTools should have a full-time team working on nothing but SmarterMail synchronization issues with email, calendar, notes etc.
 
This will pay SmarterTools back many times over in the long run, and cause many fewer email consultants and clients to run screaming for the exits.

The "cloud" is beckoning, and there are still many email admins who, for many reasons, see the good in not going there right now, and keeping their email "local."  SmarterTools, please get with it! Your very survival in the enterprise depends upon it.
 
0
Mike Ingram Replied
Update - any suggestions??
 
The tech at smartertools did find the 403 forbidden errors on my server.. When the Outlook client does a post to OPTIONS for the Activesync connection, it results in a 403 forbidden error. When checking the handler mappings in IIS for activesync, the POST/OPTIONS methods should be passing without issue, but are getting hung up.
 
After having the crash happen to me again a little while ago, I tried to access webmail before a reboot on the same computer and it would not log in properly and gave me a 403 forbidden error in webmail... SO, activesync to smartermail some how triggers a 403 forbidden error and then the whole computer/session can not access the server (outlook or webmail) for any email account (I tired other email accounts as well) until the computer is rebooted. I am at a loss and I hope someone can help soon. The few active sync enterprise clients I put on this server are going to jump ship soon and I do not blame them at all.... I was going to move more clients to my smartermail server but just can't get myself to do it :(
 
Any suggestions from anyone??
 
Thank you for reading!!!
-Frustrated smartermail customer
0
Mike Ingram Replied
This may be my configuration on my server.. I am using hostgator with a dedicated server, and I did not set up smartermail to start with but I may have multiple listeners in IIS. More to come.. hopefully getting closer!!!! I will keep this updated....
1
Mike Ingram Replied
Made some changes and testing now... so when I got the dedicated server at hostgator, smartermail was already installed and configured and they use plesk on their servers. IIS had two smartemail sites running - smartermail and smwebmail.... being new to smartermail I do not know if hostgator set it up this way or when I did a uninstall, reboot and re-install of smartermail for upgrades (weird way to upgrade a product) if it added the 2nd IIS site or not - although I do not think smartemail adds an IIS site during install but not sure. This has been set up this way from the beginning so no wonder I was having issues the whole time.. if this turns out to be the issue. It is very hard tracking down problems and I hope this makes it all better!!! Kyle from smartertool support has been very good but this has been a very long process to get to this point. I will update for others if they see similar issues and need somewhere to look/start.
0
Tim Uzzanti Replied
Employee Post
Mike, that would have been a configuration made by Hostgator and is not recommended. I think we have a contact for someone there and might reach out to them and give some guidance for future customers. I hope all is good and your up and working! Kyle is great at what we does... your in good hands! Thanks, Tim
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Mike Ingram Replied
Well, the issues are still happening to my users. There is only one IIS site running and still having problems with the errors. I thought we had this solved but then I just asked one of my clients and they said it never stopped happening for some user.
 
Still having sync issues with this error.  :(
 
 
0
phillip Replied
Some HTTP servers, firewall, content filtering systems, etc. block OPTIONS requests. I don't recall the history behind it but I believe its either a newer HTTP verb or one that was not widely used until REST got popular.

I was working with another tool that was also making OPTIONS requests that were being dropped. I ultimately had to upgrade the web server to one that would support the HTTP verb.

IIS is clearly tested by SmarterTools but perhaps you have some kind of router/load balancer/firewall/HTTP caching server/etc sitting in front of your end points manipulating requests.

Reply to Thread