SOS, ports not listening after updating to latest SM 14 build
Problem reported by devang - 5/3/2016 at 8:20 AM
Submitted
Hello,
 
After updating to latest SM 14 build 14.6.5955 & restarting my Windows 2012 R2 server, None of the ports is listening 
 
Windows Firewall is disabled, i've restarted SM service but none is working, even basic port 25 & 110 is also not working, we've also installed Comodo SSL on it
 
We can send mails using Web interface 
 
Please advice what can be wrong & what can be done to resolve it 

4 Replies

Reply to Thread
0
devang Replied
After restarting SM service twice, ports have started working
 
I am puzzled as what could be the issue about such erratic behavior of SM where all ports stopped working after restart  & started working only after SM service restart 
 
anyone has some solution to such issue? 
0
J Smith Replied
I've had a similar issue when upgrading to v12 from v10, To resolve the issue I deselected the ports from the IP address (Settings -> Bindings -> IP addresses) and saved then I restarted the mail service and selected the ports again.
1
devang Replied

in my case. mailservice.exe process did not fully start, or was stuck in an orphaned state, restarting SM service worked for me

Most of the time these issues surface is due to high disk IO during the startup phase of Windows, Setting the SM Service to Delayed Start [in Services] allows SmarterMail to start after all of the core windows services 

I hope this will help  
 
0
Assin Ontivi Replied
This "Delayed Start" workaround should NOT be needed. SM should do more "housekeeping" upon service startup and make sure these ports are communicating.

Reply to Thread