Windows Phone POP not downloading beyond email headers
Question asked by dave - April 27, 2016 at 5:20 AM
Unanswered
SmaterMail Pro 14.4.5801
 
Trying to troubleshoot a Windows Phone that is able to get the mail headers via POP but when in a specific email and asking it to download the rest of the message it never completes.  It does this same behavior for multiple/all email accounts on this same server.
 
Turned on POP detail logging and snagged the following (x's replace possibly sensitive info):
 
00:10:37 [xxx.xxx.xxx.xxx][57381393] connected at 4/27/2016 12:10:37 AM
00:10:37 [xxx.xxx.xxx.xxx][57381393] CAPA
00:10:37 [xxx.xxx.xxx.xxx][57381393] AUTH
00:10:37 [xxx.xxx.xxx.xxx][57381393] -ERR Invalid command
00:10:38 [xxx.xxx.xxx.xxx][57381393] USER xxxxx@xxxxx.xxx
00:10:38 [xxx.xxx.xxx.xxx][57381393] PASS XXXX
00:10:38 [xxx.xxx.xxx.xxx][57381393] xxxxx@xxxxx.xxx logged in
00:10:38 [xxx.xxx.xxx.xxx][57381393] STAT
00:10:38 [xxx.xxx.xxx.xxx][57381393] +OK 35 443177
00:10:38 [xxx.xxx.xxx.xxx][57381393] UIDL 35
00:10:38 [xxx.xxx.xxx.xxx][57381393] uidl for message 35 given
00:10:38 [xxx.xxx.xxx.xxx][57381393] QUIT
00:10:38 [xxx.xxx.xxx.xxx][57381393] disconnected at 4/27/2016 12:10:38 AM
 
The "ERR Invalid command" is the rub I'd imagine .... but with the log level at Detailed I'm not sure how to get more specific information to determine the root problem.
 
Any suggestions on what the problem is or how to find the problem?

1 Reply

Reply to Thread
0
The problem turned out to be some sort of problem with a particular email downloaded to the device in the past ... maybe.  Found that the device had almost 45 days of emails on it when it was configured for 7 days.  Given that it would download the headers but not the remainder and given that it reported last successfully "sync"ing 30 days ago, we deleted all emails on the device that were older than 7 days.  Now the device works as expected.
 
So apparently a prior email on the device was the trigger to the error.

Reply to Thread