TLS issue
Question asked by Russ Michaels - March 15, 2016 at 1:08 PM
Unanswered
I am trying to set smartermail to allow TLS but am having problems.
I have enabled TLS on ports 25 and 587, and if I do a test from mxtoolbox it says TLS is supported.
But any app which sends mail through this server fails as soon as I tell it to use TLS.
 
why ?

4 Replies

Reply to Thread
0
I think we need more info to answer that question...
Do you have a SSL cert. Is it self signed or CA created, have you bound IIS to smartermail. Have you bound imap, pop3 ports to SSL also.
Did you enable TLS on the server registry..????
These 2 links were useful to me. https://portal.chicagonettech.com/kb/a54/configure-ssl-tls-to-secure-smartermail.aspx

http://portal.smartertools.com/kb/a2671/configure-ssl-tls-to-secure-smartermail.aspx
0
Karl,
 
yes I have a CA wildcard SSL cert that we use on several websites.
yes smartermail is bound to IIS, this is not a new server, it has been in use a few years,
TLS is enabled, the server gets an "A" on the qualys ssllabs 
 
0
You could use IIS Crypto to enable or disable TLS in the registry.
"www.nartac.com/Products/IISCrypto/Download"

 
1
Can you look in the SMTP logs... what are the SMTP logs saying when negotiating a TLS connection.
Also check and make sure that authentication on the client is enabled on port 587 connections.
I had a problem where all the mxtoolbox, IIScrypto and autodiscover smtp/imap tests etc all passed. I used this tool https://slproweb.com/products/Win32OpenSSL.html to show that there was a error and i had to re-export the SSL cert and everything worked after that.

Reply to Thread