enhanced-logging-for-iis not being trapped in smarterstats
Question asked by Manju Malhotra - October 14, 2015 at 12:53 AM
Answered
Hi 

One of our customer has taken DDos support and this caused real IP of customer not being logged in weblogs, for that below logging option were enabled in IIS and DDos service provider .

Then we start seing the real IP under custom column which is done after adding column in IIS "Enhanced Logging"
iis. net/learn/get-started/whats-new-in-iis-85/enhanced-logging-for-iis85

Though this is not reflecting in smarterstats*.
 

* Changes done in Smarterstats : login to Website stats go to Settings --General Settings -- import filters - add -- import filter-- "Include a Host Header" from drop down and added column name "Real-IP" which is being added in weblogs after above IIS changes.


above changes stops showing any entry in reports as
filter is active, even old logs reports are not showing up.
 
We would like to replace "c-ip" in IIS logs with "Real-IP" only issue we can not do it in IIS logs or Smarterstats.
 
Thanks in advance

2 Replies

Reply to Thread
1
Employee Replied
Employee Post Marked As Answer
Hello,
 
Currently SmarterStats does not have an option to account for load balanced type of sites as you described.  That being said, this is something that is being reviewed and added into the next version of SmarterStats as it is becoming more common.
 
Thanks
0
Ashish Pahuja Replied
Hello SmarterStats Team,

We are using version SmarterStats Enterprise Edition, Version 9.3.5409.

Can you confirm if the feature is now available? We would like to upgrade and renew our license.

Regards,

Reply to Thread