Google Migration - calendar time zone issue
Problem reported by kevind - August 10, 2015 at 2:26 PM
Resolved
When importing a Google (Gmail) calendar using the Mailbox Migration, it looks like SmarterMail 14.1 uses the server time zone instead of the time zone of the Google Calendar.
 
For example, if you import a Google calendar with Pacific time, and the user's SmarterMail profile is Pacific time, the 8am event will display as 11am because the server is Eastern time.  If the server's time zone was set to Pacific, it works fine.
 
Thanks,
Kevin

6 Replies

Reply to Thread
0
Matt Petty Replied
Employee Post
From the code I'm looking at we use the user's time zone not the server's, can you verify that your user your importing into isn't set to use the server default timezone?
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
kevind Replied
I don't know -- maybe I'm doing something wrong. Here are the steps to duplicate:
 
Log into Windows Server
  1. verify time zone set to Eastern.
Sign into Google Calendar
  1. verify that time zone is set to Pacific.
  2. create an event for 8:00am tomorrow -- Breakfast at Tiffany's
Sign into SmarterMail
  1. go to Account Settings -> User tab -> Time Zone and verify that it's set to Pacific
  2. run the Mailbox Migration tool
  3. go hungry tomorrow because the calendar says breakfast starts at 11:00am.
0
Matt Petty Replied
Employee Post
This has been fixed and will be in our next minor.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
kevind Replied
Nice! Looking forward to scrambled eggs, toast, & juice. :)
0
Matt Petty Replied
Employee Post
I didn't get the reference earlier until I went to Google to do some testing :p
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
kevind Replied
Confirmed that this works as expected in 14.2. Thanks!!!

Reply to Thread