Admin Account Locked Out
Question asked by Francis Gibbons - July 22, 2015 at 8:54 AM
Answered
Hello All,
 
I am running SmarterMail 9.x on a Windows 2008 Server. I have been running this for a few years and all has been fine until last week. When I try and login to SmarterMail using Admin user name and password it keep telling me user name or password incorrect. So then I click on Forgot Password to try and retrieve my login info. When I put my email address and the captcha info it tells me "Your Account is Locked or there is no backup address on file. Please contact your system administrator to regain access." Only problem is I am the system admin. 
 
I tried to reset my Admin username and password back to default using the following SM document which I can't post the hyper link they wont allow me but here is the help document.
 

On occasion, you may need to reset the system administrator password. This is useful in the event that the primary administrator has lost the password.

Applies to SmarterMail 7.x - 14.x

Follow these steps to reset the primary administrator login and password:

  1. Stop the SmarterMail service.
  2. Navigate to the SmarterMail directory. By default, this will be C:\Program Files\SmarterTools\SmarterMail.
  3. Open the Service subdirectory.
  4. Make a backup copy of the file MailConfig.xml.
  5. Open the MailConfig.xml file in Notepad.
  6. Find the section that looks like this:
    <!-- ** System Admin *************************** -->
    <!-- ** To reset admin password, delete these items ** -->
    <!-- ** and then restart the SmarterMail Service. ** -->
    <!-- ***************************************** -->
    <sysadminusername> ... < /sysadminusername>
    <sysadminpassword> ... < /sysadminpassword>
    <!-- ***************************************** -->
    
  7. Delete those lines and save the file.
  8. Start the SmarterMail service.

You should now be able to log in to SmarterMail using the default username and password:

  • Email: admin
  • Password: admin
 
I did exactly what it said stop all services including IIS, deleted my login info in the mailconfig the two lines then saved and restarted services. Try to login as admin and admin and it rejects me.
 
Can someone PLEASE help me. I have active clients on this server and need to get in. I don't have a backup email account but shouldn't matter because I gave it my active email address and it should have resent me a reset email. Which mail is working fine but I can't access anything!!!!!!!!!!!!
 
Please help,
 
Frank G.

10 Replies

Reply to Thread
0
Matt Petty Replied
Employee Post
You could try instead of deleting those two lines you could replace them with

<sysAdminUserName>admin</sysAdminUserName>
<sysAdminPasswordHash>1000:9uUnwWeI/btFlx4dcjLJvOw15bESIOP5:4PZINOg0hvzwZGOps0SZvAmHjD4GdCFZ</sysAdminPasswordHash>

This equates to 
user: admin
pass: admin

This requires a restart of the mailservice.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Francis Gibbons Replied
Hello Matt, I gave that a try and no go. As you mentioned I copied the two lines and replaced in my mailconfig file. Stopped services, replaced , saved and restarted services. Went to webmail entered admin and admin and says email address or password is incorrect. Good suggestions was really hoping that would have done it. Any other ideas or suggestions??? Thank you!
0
Matt Petty Replied
Employee Post
I'm not sure what else to do. You could try calling support or creating a ticket but just keep in mind that Version 9 is considered legacy and so support may be hit or miss.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Francis Gibbons Replied
Yea I created a ticket. I just don't have the extra cash right now to upgrade to 14 :( I hope they can help me figure it out. Just seems very weird!! Thanks!
0
SpamHurts Replied
What happens when you change the file, and re edit it. did your changes get saved? My guess is your are not saving this correctly. And you must stop SM while editing. Change the file, the save. Then re edit, did your changes get saved? IF so, restart SM,,,,
 
Remember kids, every time a spam message gets blocked, a nerd gets their glasses. spamhurts/July 15
0
Francis Gibbons Replied
Hello SpamHurts, I did it the way the instructions said to. I stop SM 9 buy going to programs > Smartertools > SmarterMail Web Config Server and clicked Stop under Service Manager. Then I even opened IIS and stoped IIS because I have smartermail in there for webmail. I then went to Smartertools > SmarterMail > Service. I opened mailConfig.xml and removed the two lines for user name and password. At this point I clicked on Save and closed the file and restarted Smartermail Web Config and then started IIS. Went to Webmail on my browser and tried admin and admin for user and password. Says incorrect user name or password. It seems like nothings happen but the mailconfig file is showing me saved changes when I reopen it. Is it possiable SM could be using another mailconfig file somewhere else? I did a full search on my C drive to find all mailconfig.xml files. Waiting for that to finish but is there a way to open a text file in SM and see what the path is for the mailconfig file to make sure I am editing the correct one? For the fun of it I stopped all services and renamed the mailconfig.xml file to test mailconfig.sml. Then restarted SM to see if it would toss an error and it didn't it started right up. But if its using a different mailconfig file how do I know which one its using and the location? Thanks for your help!!
0
Francis Gibbons Replied
Marked As Answer
Okay I got it finally. Using my login info. Very wierd... I logged in using my localhost url directly on the server. I was able to modify my admin account and update it. I can't thank you guy enough for the help. Maybe it was using the localhost url that did it. I don't get it but its working now!! Thanks again!!!
0
Brian Ellwood Replied
If localhost did it, then its possible the FQDN was pointing elsewhere and why nothing seemed to work.
0
Paul Blank Replied
I tried this and it didn't work, until I stopped the service in Windows (services.msc) - or from command prompt: NET STOP "smartermail service" ....
0
Hi, i have the problem same you, how you solve the problem?
i really can't login to admin account so, i try to delete lines and finally not OK!
PERSIAN GULF

Reply to Thread