Strange problem - 550 Authentication is required for relay
Question asked by Rafael Grecco - July 13, 2015 at 1:29 PM
Answered
Hi,
 
I am having a problem with this error message: 550 Authentication is required for relay when someone tries to send e-mail from Google Mail Service to my costumers (I run a ISP with several hundred domains).
 
Someone forwarded this message to me:
 
From: Mail Delivery Subsystem <mailer-daemon@googlemail.com>
Date: 2015-07-07 13:43 GMT-03:00
Subject: Delivery Status Notification (Failure)
To: xxxxxxx@sender.com

Delivery to the following recipient failed permanently:

 
xxxxxxxxx@recipient.com (hosted by me)

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain recipient.com by my.smartermail.server. [xx.xxx.xxx.xxx].

The error that the other server returned was:
550 Authentication is required for relay
 
I renamed the sender, recipient and my e-mail server adressess.
 
The recipient is hosted on my Smartermail server and I have never had this problem before (that I know). I was contacted by the sending party, the one that received the error message.
 
Below is the original message (which he also forwarded to me):
 
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20130820;
        h=x-gm-message-state:mime-version:disposition-notification-to
         :in-reply-to:references:date:message-id:subject:from:to:content-type;
        bh=PG7tMYn83O0XhalIz8Vd9nEjHTJ/guXMT4PLHAWF2J0=;
        b=LcrTL6e09o1UjeWqVKXj3KjqvLvGfgscpm7uHiO2pAuBwCDbDzxwDokNDGl7DBhlHc
         7tfLw0Eb6WLn6XpLxxe2Gy4VEHE/yLvj38xoX7nHd2DeoizXDJs48PDz4Mx08McaloKh
         TGhNbQLi3QtwUmG8Y/hFGUWOHpuYG3G+OHzvxFLd3tpGYJKtzoBRcFKOm+6XGrqPHE4P
         SKig4eq3CnHSDQqUr0lZY4KKzUVyCzMl+geGuOuatTG97ej6nLgazCJKddf5mceRGPzT
         m6yUfbBOdmZT0rHBJ+nfoIbggQ6yxPeValCi60QsK/CVBRwjvqBXaY/Xz1ch3Xp5ObFH
         rNEQ==
X-Gm-Message-State: ALoCoQk0YhJ3cNpp9ARC8kUajO6b3aii0Hfl0tjA6ebuuNESRhj1SmjMqBsrFtRo095aa7oN3xaz
MIME-Version: 1.0
X-Received: by xx.xxx.xxx.xxx with SMTP id dh2mr4340446lac.53.1436287417619;
 Tue, 07 Jul 2015 09:43:37 -0700 (PDT)
Disposition-Notification-To: xxxxxx@sender.com
Received: by 10.25.17.25 with HTTP; Tue, 7 Jul 2015 09:43:37 -0700 (PDT)
In-Reply-To: <CAEBSmxk6YrekC9mcg59nCzix79-F6vvRPioDH7Gj2mfGQUyHdw@mail.gmail.com>
References: <BLU173-W46C172F518B96A7915284AF4960@phx.gbl>
        <CAEBSmxk6YrekC9mcg59nCzix79-F6vvRPioDH7Gj2mfGQUyHdw@mail.gmail.com>
Date: Tue, 7 Jul 2015 13:43:37 -0300
Message-ID: <CAF3EyhGqaNuhA8KbemO7suYc8cbMjkOeCxEF=mfeExEBgFqd6g@mail.gmail.com>
Subject: Fwd: E-mail subject
From: Sender <xxxxxx@sender.com>
To: xxxxxxxx@recipient.com (hosted by me)
Content-Type: multipart/alternative; boundary=001a113497e452aeb9051a4bb92b
 
So....... do you know what the problem is? Can I fix it or should the sender contact his e-mail service (Google)?
 
Thanks

10 Replies

Reply to Thread
0
Employee Replied
Employee Post
I recommend to take a look at your SMTP logs to see if there is some additional information there.
0
Rafael Grecco Replied
Hi Brian,
 
The log shows the exact same error:
 
rsp: 220 email.myserver.net
connected at 07/07/2015 12:43:28
cmd: EHLO 250 mail-la0-f52-google.com
rsp: 250-email.myserver.net Hello [209.85.215.52]250-SIZE 31457280250-AUTH LOGIN CRAM-MD5250 OK
cmd: MAIL FROM:<xxxxx@sender.com> SIZE=15426
rsp: 550 Authentitcation is required for relay
cmd: QUIT
 
 
0
Rafael Grecco Replied
Does anyone know what could be happening? Is this a Google problem? Is it a misconfiguration on my part?
0
SpamHurts Replied
This looks like a problem from the senders end. They are sending it without proper authentication.  You don't want email without proper authentication coming into your server.
 
I have a question. In your smtp log, this line:
cmd: MAIL FROM:<xxxxx@sender.com> SIZE=15426
 
is the sender a gmail address? Or is it a hosted domain, that is using google apps? Either way, it sounds like the sender is using an email client (phone, outlook, mac mail etc.) that isn't authenticating correctly. This is just a guess, but perhaps others will chime in.
 
You can test if gmail can send to your server easy enough, just create an account on one of the hosted domains, and send to it from your own gmail account, then look at the logs for comparison.
Remember kids, every time a spam message gets blocked, a nerd gets their glasses. spamhurts/July 15
0
Rafael Grecco Replied
It is a hosted domain. They use their own domain on Google.

My first thoughts were exactly lack of proper authentication, but they said they send e-mails directly from webmail.

And this is where things get wierd. They can send me e-mails, but I am on another server. I think I´ll make some more tests and post the results here.
0
SpamHurts Replied
Okay, you have got me curious.
209.85.215.52 is def google.
 
This line here though
Received: by 10.25.17.25 with HTTP; Tue, 7 Jul 2015 09:43:37 -0700 (PDT)
That range, that seems like a apple device. I am not convinced they didn't use an email client. but hard to argue with with HTTP;  Customers don't always..... tell the..... admi...hmmm... sometimes they get confused with our questions and their answers do not meet our criteria :P
 
What did your delivery log say? a bounce email was written.. so there are a few lines, probably nothing helpful.
 
I would set up a test google account. Connect with an email client. Send to a test account that you create on your customers domain. Send from google web mail, and one from google/outlook (email client)
 
If at all possible, have this other company, that has been pretty helpful send to your test account on your customers domain.
 
Your issue really has me curious, Let me know how it turns out.
Remember kids, every time a spam message gets blocked, a nerd gets their glasses. spamhurts/July 15
2
Rafael Grecco Replied
Marked As Answer
You won't believe how simple it was and I am kind of embarrassed of posting the outcome here :P
 
It happens that this guy that uses the Google e-mail service didn't tell me, but he was actually a ex-customer of mine.
 
I have some e-mail servers and a few hundred domains hosted on my servers, so I can't remember them all. For some reason, this guy didn't cancel the service with me so it was not deleted from my server.
 
As you can imagine, everytime he tried to send a e-mail to another domain that was on that same server, it would be rejected with the "authentication error".
 
That is what happened ...
 
Thank you for the help!
0
SpamHurts Replied
Thanks for the update!!I bet this post saves hours of frustration. You're welcome users of the future!!!
Remember kids, every time a spam message gets blocked, a nerd gets their glasses. spamhurts/July 15
0
Michael Lewis Replied
Rafael,

What did you end up having to do to resolve this? Did it resolve itself once you deleted the domain from your servers?

Thanks,
Brent
My Other suggestions: http://bit.ly/segoideas
0
Rafael Grecco Replied
MIchael, sorry for taking so long to answer your question, I was on vacation!

Yes, I only had to delete the domain and everything went back to normal (maybe you could have to restart your server due to cache and stuff).

Reply to Thread