Role Permissions Not Working For Users/Organizations
Problem reported by Ben Santiardo - 5/7/2015 at 7:58 AM
Resolved
SmarterTrack v11
 
When assigning a role "Read Only" rights to "Users / Organization", the setting has no effect on the "Organizations" section. An employee designated with Read-Only access still has full control over organization records.
____________________________________
Ben Santiardo, Programmer Analyst
Eastern Suffolk BOCES

5 Replies

Reply to Thread
0
Employee Replied
Employee Post
Hello,
Thank you for reporting this. It has been fixed for the next SmarterTrack Version.
Cheers,
 
0
Ben Santiardo Replied
Is there an ETA on when that release will be? Just curious.
____________________________________
Ben Santiardo, Programmer Analyst
Eastern Suffolk BOCES
0
David de Villiers Replied
Hi Ben, Just a quick question, I can't seem to find any way to assign a Role to an Organization (Only to users). I am missing some thing?

Any advise would be greatly appreciated.

ps. I am a complete SmarterTack newby, (only been playing for 2 days).
pps. Version 11.4
0
Ben Santiardo Replied
No problem! :-) I know how tricky it is sometimes to find certain settings, there is so much out there.

Once logged into the Management Portal...
1) Click the gears to enter the settings section
2) Expand the "Manage" tree
3) Select "Roles"
4) Double-click the role you wish to control U/O settings for
5) At the very bottom you see "Users / Organizations"

P.S. You cannot assign a role to be able to see just one of the U/O sections (ie: Users or Organizations), it's an all-or-nothing setting.

Hope this helps!

-Ben
____________________________________
Ben Santiardo, Programmer Analyst
Eastern Suffolk BOCES
0
David de Villiers Replied
Aaaa...
Thanks Ben, you are referring to an Employee-Role and I was staring at an User Role. ;)

I was hoping to find a way to apply a User-Role to all users in an Organization.

Kind regards
David

Reply to Thread