Smartermail 64 Bit: Windows Server 2012
Question asked by Michael Barber - 11/15/2014 at 9:35 AM
Ok our server crashed yesterday and management wants us on Windows Server 2012...they says its almost the end of 2014 and yet we are not even on 2012 and soon it will be 2015.
Ok, first thing, server 2012 ONLY comes in 64 bit flavor and now we have to recover our smartermail backup and restore it from 32 bit to 64 bit operation.
Ok, bleeding edge questions:
  1. Will SmarterMail run on 64bit, windows server 2012 ?
  2. Are there any issues or special things we need to do in order to run it with IIS 8 ?

7 Replies

Reply to Thread
M. Hussein Replied
SmarterMail works perfectly on Windows server 2012.
Michael Barber Replied
I did a straight install and its not working at all trying to use the standard web server that it comes with and its not working at all. Is there a list of extra things that have to be done...because out of the box, its a fail!
Michael Barber Replied
I installed it to try and get it work with IIS 8....and this error shows up....where xx.xx.xx.xx is a disguised IP address.  Some kind of asp.net error.  The app pool is 4.x.  I gave the IIS_users  RX permission to the /MRS folder.

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information:

Module    IIS Web Core
Notification    BeginRequest
Handler    Not yet determined
Error Code    0x80070021
Config Error    This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File    \\?\C:\Program Files (x86)\SmarterTools\SmarterMail\MRS\web.config
Requested URL    http://xx.xx.xx.xx:1998/
Physical Path    C:\Program Files (x86)\SmarterTools\SmarterMail\MRS
Logon Method    Not yet determined
Logon User    Not yet determined

Config Source:

  103:     </httpProtocol>
  104:     <handlers>
  105:       <remove name="OPTIONSVerbHandler" />
Michael Barber Replied
Not sure what this is. I've added "EVERYONE" as permissions to the /MRS folder and that didn't help. I modified the host headers to localhost so I don't have to edit the shortcut. It still doesn't work. Mind you, it won't work with IIS or the SmarterMail webserver, either one, out of the box.
Michael Barber Replied
Ok, I can actually get to the admin panel now.  You need more documentation Smartertools.  2012 is a beast.  It takes 2008 to the extreme level.  I had to enable many more services besides .net that don't automatically turn on anymore like they did in 2008 if you set up an asp.net application server.  So I had to make sure cgi and isapi extensions were on.
However, I'm still not 100%.  I can't telnet to the mail server on port 25 or port 110 and I have opened both of these ports on the firewall.  I'm not sure what that is yet.  Honestly I hate 2012.  Everything that sucked about 2008 has been taken to an extreme level in 2012.  Its like they are trying to take a server admin box and turn it into a Google chrome browser.  Absolutely STUPID.  Server admins want access to all the controls.   Hiding them just means we have to work harder to go and find everything to turn it all back on.
Anyway, it is NOT a firewall issue.  I've disabled and turned the firewall off and I still can't get to port 25 or port 110...so the mail server must not really be running correctly yet.
Michael Barber Replied
Ok it was that the license had to be reactivated on the restored server.
Jacques Milon Replied
What's the solution to this? I just ran into the same issue?? But using Windows Server 2008 64-bit

Reply to Thread