iPhone SMTP not working
Problem reported by Antoin Currie - April 24, 2015 at 8:39 AM
Submitted
Hello there,
 
I have a requirement from a client to set up their iPhones so that they can send and receive emails on them connecting to our smartermail server.
I have followed a guide for setting this up on iphone, I would love to share this with you but apparently my account does not have permission to use hyperlinks in posts.
It was from this forum.
 
However, when they try to send an email using SMTP, it doesn't work at all.  It just sits in the outbox forever and doesn't move at all.
 
I don't get anything in the logs on the server for this as it doesn't even seem to make the connection.  I'm not even using encryption.
 
This works perfectly on all my android devices, but for some reason SMTP doesn't seem to work with these apple devices.
 
Anyone seen this happen before? They're iphone 5s
 
Thanks 

5 Replies

Reply to Thread
1
We experience this problem every single time iOS updates their software. I don't know why they overwrite the Mail Settings for existing accounts, but they do. This can be fixed as per my post at
 
Apparently iOS updates change all previous SMTP settings to MD5 Challenge-Response. The resolution is as follows:
 
  1. From the home screen on your device tap Settings, and then Mail, Contacts, Calendars.
  2. Then tap the email account under Accounts.
  3. Tap Account.
  4. Scroll down and tap SMTP under Outgoing Mail Server.
  5. Tap on your Primary SMTP server.
  6. Tap Authentication.
  7. Change MD5 Challenge-Response to Password.
  8. Tap the button on the top left to go to the previous screen, then click Done.
Note that once Smartermail v14 is released this won't be a problem any longer as MD5 Challenge-Response will be an option that Smartermail v14 recognizes (despite it being a deprecated method...but since Apple insists on defaulting all accounts to it might as well placate them).
0
Hi there,
 
Thanks very much for responding to me!
However, I already checked all that, the authentication was already set to Password so I'm still stuck!
Can't send a thing!!!!
 
Help!!!
 
Cheers
 
Antóin Currie
0
By the way I'm using smartermail v 8.4
 
Would this be an issue?
0
Antion:  SmarterMail 8.4 is very old, going back to 2008, and SmarterMail 14.X is in BETA right now.  Technically, SmarterMail / SmarterTools only supports the current, and last two, generations of a product, so I would seriously consider upgrading your version of SmarterMail to the most current version:  SmarterMail 13.3.5535, and, when it is released, 14.X.
 
SmarterMail 13.3 is must faster, and much more secure, than SmarterMail 8.4, and SmarterMail 14.X will bring additional features.  Note that SmarterMail 14.X requires .NET 4.5.
 
Both SmarterMail 13.3 and SmarterMail 14.X bring new connectivity for smart phones because they have resolved many issues with POP3, IMAP, and SMTP protocols.
 
If you want a personal, test account, to see the benefits of SmarterMail 14.X, please contact me off-list, and provide me with your e-mail address so I can setup a test account on one of our test domains for you and e-mail you credentials.
 
You can play with the web interface and also attempt to connect the user's iPhone, via IMAP or POP, and see the difference in both the capabilities, and response, in the more recent version(s) of SmarterMail.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
On iPhone 6s, I had to re-enter the username and password for the Outgoing server "optional" settings again and marked the Password method in Authentication for the server settings. otherwise I kept receiving < rsp: 550 Authentication is required for relay >

Reply to Thread