GetTicketAttachments Web Service issue
Problem reported by Justin Anderson - 4/21/2015 at 6:14 AM
I am currently using version 10.6.5584.20344
This web service does not always return Files when it should.  If I use your UI, i can see an attachment in the Attachments tab as well as seeing it inline to the message.  This example is a .jpg attachment (if that matters).  If i call the web service against that same ticket Id, it says there are no results.  I know it's not an issue with my code because if I run it against another ticket number (one with 3 attachments) i see all 3 files.  I am not sure what i can do to help with this.  I tried looking in the DB and if i pull from "TicketAttachments" table i can see the attachment there.  I can also download it via your web UI.  
couple more data points:
  • It's not an issue based on the number of attachments because i pulled another ticket with 1 attachment and it was fine
  • It could have something to do with the fact that this jpg came from an email attachment (in the signature line when they submitted a ticket reply via emaill)
I am lost...

Reply to Thread