1
can not connect to smartermail on windows server 2012 r2
Problem reported by Stefan - 2/25/2015 at 2:01 PM
Submitted
Hi,
 
I am migrating my mailserver from windows server 2003 (64 bit) to server 2012 R2. Webmail is already up and running on https (iis 8), but unfortunately I can not connect to imap service on port 993. It was perfectly working on 2003 (smarter mail v12). I transferred the configurations to my 2012 server, changed all ip-configurations accordingly and created a new certificate. I get no information in the logfiles (all log levels set to 'detailed'). Disabling the firewall doesn't change anything. I can connect to port 993 by telnet and portqry.exe. I tried both smartermail v12 and v13.
Are there any special settings in 2012 R2 that I missed?
 
Best regards,
Stefan

10 Replies

Reply to Thread
0
Steve Reid Replied
Check the bindings in Smartermail to ensure it's not holding onto the old ip.
0
Stefan Replied
Thanks Steve - I am sure I double checked those settings, but I will check again.
0
Steve Reid Replied
I usually open the smartermails config file directly and do a find and replace... I think you need to ensure the domain is not set to the old ip as well.
0
Joe Wolf Replied
Port 993 is for IMAP SSL. There are no longer any valid SSL configurations and Microsoft has sent out several updates to remove SSL from Server 2012+. So in effect you have nothing that can answer on 993. Change to Port 143 TLS and the problem will be solved.
Thanks,
-Joe
0
Stefan Replied
I checked all config files again: all IPs and other network settings seem to be right. When I change to plain imap and smtp my mail client can connect without problems.
0
Stefan Replied
Thanks Joe. But unfortunately TLS doesn't work either. I do not understand why webmail does work with ssl, but imap and smtp does not???
0
Joe Wolf Replied
Well your being confused with the term "SSL". When you connect to https://mail.yourdomain.com and you see the green lock or whatever your browser does... click on that lock and you can drill down to the actual connection type and you'll see it's really connected via TLS not SSL. Check your server at https://ssllabs.com/ssltest/ and I'm pretty sure you'll find that your sever doesn't support any SSL versions.
Thanks,
-Joe
0
Stefan Replied
Joe, I managed to activate SSL on my server following this thread: http://www.adminhorror.com/2011/10/enable-tls-11-and-tls-12-on-windows_1853.html Now my mail clients can fetch mails from my server; BUT next problem: my new server doesn't retrieve mails from external mail servers as the old one did... again no entries in the smartermail logs :(
0
Joe Wolf Replied
No, not good. Download IIS Crypto from: https://www.nartac.com/Products/IISCrypto/IISCrypto40.exe Just put it on your Desktop... it's just one file and doesn't install. Run IIS Crypto then hit the "Best Practices" button, then "Apply" then reboot. That will do it properly and probably fix your problem. If you'll post your server name I'll run some tests.
Thanks,
-Joe
0
Stefan Replied
Unfortunately IISCrypto didn't fix my problem - I will open a new thread because the original issue was solved due to your tip - thanks again

Reply to Thread