Log files from Clam - "LOGGING DISABLED (Maximal log file size exceeded)."
Problem reported by Webio - February 6, 2015 at 12:07 AM
Submitted
Hello,
 
can ST SmarterMail dev team create some kind of log rotate for ClamAV log files? When they (clamd and freshclam) are exceeding 5MB and 1MB size only thing added to this logs is:
 
"LOGGING DISABLED (Maximal log file size exceeded)."
 
and since I'm getting errors like:
 
[2015.02.06] 01:26:46 [93823] Unable to run Clam virus checks: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 127.0.0.1:3310
[2015.02.06]    at MailStore.Spam.ClamDClient.CheckScan()
[2015.02.06] 01:56:57 [94345] Unable to run Clam virus checks: System.Exception: ClamD connection timed out
[2015.02.06]    at MailStore.Spam.ClamDClient.CheckScan()
I would like to investigate it a little and log files without information are useless here.
 
Thanks
 

2 Replies

Reply to Thread
0
Employee Replied
Employee Post
Hello Webio,
 
Thanks for the inquiry. I have observed the log file to exceed the default values.  I believe the limit is set to 1MB. Please look into either copying the two Clam files [freshclam.conf  | clamd.conf] out of the following path: [C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam\etc] and then deleting the files and they will be rebuilt.
 
You can opt to modify the Clamd.conf file to increase the size limit. Since the ClamAv is a third party application you may want to refer to the documentation on ClamAv's website for more specifics.
 
Thanks.
0
Steve Reid Replied
When running Smartermail with the components it includes it is safe to say it's expected that logging is not deleted.
 
Hopefully ClamAV is ditched in favour of something else that actually works properly. However if ClamAV is kept than Smartertools should change these log settings and perhaps the log path.

Reply to Thread