Site Summary Reports won't print or email in SmarterStats
Problem reported by Gary Steiner - 2/5/2015 at 10:11 AM
Resolved
Using SmarterStats 10.0.5420, I login as System Admin.  I click on the reports button, then Traffic under Site Summary Reports.  The report displays fine.  I try to print it using the Print tab at the top.  This generates a small popup window in Internet Explorer that says Print Preview at the top.  This small window has scroll bars on the sides, as it is too small to display the whole report.  After clicking the print button in the window provided, the output to the printer displays the small window with scroll bars, not the entire report as one would expect.  This printout is worthless.  I tried doing the same thing in Firefox, and that's what I got, the same thing.
 
Thinking I could get around this problem by using the email feature, I clicked on the Email tab.  I filled out he popup with To Address and Subject, then clicked OK.  I get a little red error message, "Email failed to send."  Love those helpful, descriptive error messages.  Now, I know my SMTP is configured correctly since my daily automated email reports all were distributed no problem.  (Check the Logs under "Scheduled Email Reports" and everything was shown as expected).  Still no error message anywhere in the logs that might help me figure out what this problem is.  When an error of this type occurs, is it recorded anywhere?
 
As far as I can tell, none of the reports at the System Administrator level can be successfully printed or emailed.  Has anyone else encountered this problem?

15 Replies

Reply to Thread
1
Gary Steiner Replied
Another attempt to get around the problem.  I clicked on the Export tab, and selected PDF.  This displays an error message of
 
System.NullReferenceException: Object reference not set to an instance of an object.
   at SSWeb.Common.HttpHandlers.ReportGenerators.PdfReportGenerator.RenderReport(HttpContext context, ReportHandlerResult generatedReport)
 
Since that didn't work, I then clicked on the Export tab and selected CSV.  After all that frustration, finally some success.  Now I can try to get some work done.
1
Gary Steiner Replied
Still experiencing both print and email problems in SmarterStats 10.1.5529.
 
Problems exist whether using IE or Firefox.
 
 
0
Zimbra Saas Replied
We are also experiencing this with 10.1.5529. One thing I noticed is that the serversettings.xml file doesnt get edited when you save the SMTP settings and the UI says its saved, THere are no SMTP settings in the serversettings.xml file
2
Gary Steiner Replied
Supposedly the serversettings.xml file problem was fixed in the previous version, but I guess that's not the case.
2
Bruce Barnes Replied
I've been complaining about this problem for eight months, and nothing has been done to resolve it.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Zimbra Saas Replied
I saw that Bruce when I was searching. I am going to just try adding the smtp settings in there myself and see if that works for now. I will let you know!
1
Bruce Barnes Replied
I have done a complete uninstall and reinstall, to no resolve.  I get the same "System Null Reference" errors.
 
Hopefully, this will be looked into and resolved.
 
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Zimbra Saas Replied
Ah I see the settings now live in the C:\Program Files (x86)\SmarterTools\SmarterStats\MRS\App_Data\Config\AppConfig.xml
0
Zimbra Saas Replied
Wish I knew what the null error is all about! [3/5/2015 2:06:47 PM] Exception: Email failed to send to xxxx@xxxx.xxx. Actual exception was System.NullReferenceException: Object reference not set to an instance of an object. at SSWeb.HelperClasses.Email.EmailReportBase.DoSend() at SSWeb.Admin.Popups.frmEmailReport.DoSend(String& errorText)
0
Zimbra Saas Replied
[3/5/2015 2:06:47 PM] Exception: Email failed to send to xxxx@xxxx.com. Actual exception was System.NullReferenceException: Object reference not set to an instance of an object. at SSWeb.HelperClasses.Email.EmailReportBase.DoSend() at SSWeb.Admin.Popups.frmEmailReport.DoSend(String& errorText)
0
Zimbra Saas Replied
I think its safe to say this is a bug!
0
Zimbra Saas Replied
Ah I see the settings now live in the C:\Program Files (x86)\SmarterTools\SmarterStats\MRS\App_Data\Config\AppConfig.xml
0
Gary Steiner Replied
Hmm.  So then what's the difference between
C:\Program Files (x86)\SmarterTools\SmarterStats\Service\ServerSettings.xml
and
C:\Program Files (x86)\SmarterTools\SmarterStats\MRS\App_Data\Config\AppConfig.xml
?
 
I noticed that ServerSettings.xml has tags of ErrorEmail and ErrorSMTP, both of which are blank.
The file AppConfig.xml has several tags with SMTP in the name, none of which are blank.
 
2
Grady Werner Replied
Employee Post
The issue in this thread relating to printing and emailing server level reports has been resolved in the SmarterStats 10.2 build that was released today.
Grady Werner
Development Manager
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Zimbra Saas Replied
Very cool thank you! #upgradetime :)

Reply to Thread