Outlook says "Your server does not support the connection encryption type you have specified"
Problem reported by elance - July 24, 2014 at 11:46 AM
Submitted
Using SmarterMail 10.7, Outlook 2010 on Windows 7.
 
I am trying to get SMTP on SSL set up.  I followed the instructions here:  http://portal.smartertools.com/kb/a2671/configure-ssltls-to-secure-smartermail.aspx
 
There was a problem with the ISP not having port 465 open but I got that fixed.  I set up the port for SMTP SSL, and set the binding to the IP address.  Restarted everything as it asked.
 
In Outlook, I have the account set up with IMAP for incoming on 143, that works.  I set up outgoing as SMTP on 465 with SSL.  This account was previously working with port 25 without SSL, but I moved to a new location inside an ATT Uverse provider, and they block outgoing port 25 unless it is to their own email.
 
I get the error in the title from Outlook when I do Test Account Settings.
 
What else do I need to do to get this working?  Any help appreciated.
 
Thanks

2 Replies

Reply to Thread
0
Also, I double checked the certificate is valid, and redid the export to file.  It was just issued.  Restarted the service again.
 
In the Log Viewer I see this .Net exception, not sure what to do about it but maybe this helps?
 
Exception negotiating SSL certificate: System.NotSupportedException: The server mode SSL must use a certificate with the associated private key.
   at System.Net.Security.SecureChannel.AcquireServerCredentials(Byte[]& thumbPrint)
   at System.Net.Security.SecureChannel.GenerateToken(Byte[] input, Int32 offset, Int32 count, Byte[]& output)
   at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
   at System.Net.Security.SslStream.AuthenticateAsServer(X509Certificate serverCertificate)
   at TcpServerLib.Pooled.PooledTcpItem.ConvertToSSL(IPBindingPort setting)
   at TcpServerLib.Pooled.PooledTcpServer.#SBc(Socket , PooledTcpItem , IPBindingPort )
 
0
Okay, figured it out, admin didn't export the cert correctly.  This older post is the real way to do it, better than the kb link above.  http://forums.smartertools.com/threads/my-guide-to-secure-e-mail-with-smartermail.12000/

Reply to Thread