Run smartermail as default website when domain is visited
Question asked by Stefan Danov - January 18, 2015 at 3:36 PM
I've recently set up SmarterMail on my Windows Server 2008 R2. I have an IIS and would like to set up the web interface. However, after following the steps from the article, I still can't access anything and when I go to the domain (my domain, hosted at GoDaddy) , I get a 503 Service unavailable error. Here's the setup:
The domain has A records pointing to my router's IP address and its MX records are pointing to this same IP as well.
The routed then routes all requests to the server's internal IP on all ports.
The server's firewall is set to allow all incoming connections.
The IIS is set in the following way:
There's an application pool called SmarterMail with Network Service Identity. Managed Pipeline is Integrated and .NET version is 4.0.30319
.NET 4.0.30319 is ENABLED.
The website's physical path is C:\Program Files (x86)\SmarterTools\SmarterMail\MRS
The Binding type is http IP: All unassigned with port 80, host name is
When I go to sites, right click SmarterMail and select Basic Settings, then click on Test Settings, I get Authorization wagning: The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make Sure that the application pool identity has Read access to the physical path.
I right clicked MRS and went to security where in the permissions tab I added NETWORK SERVICE with Read and Modify rights.
The site's default document is Login.aspx
My question: What else should I do to get this thing running?

4 Replies

Reply to Thread
Employee Replied
Employee Post
Hello Stefan,
Thanks for the inquiry. I would like to assist you further with this issue. I observed that you should be able to connect to the SmarterMail web url through the default web server port :9998.  I presume there may be an issue with the IIS settings or the Network Service account that may not have full control over the SmarterTools folders. Can you also please confirm if the Mailservice.exe is running in the Task Manager.
Please consider opening a Support Ticket for us to review the server configurations.
Thank You.
Hello Joseph,
Thanks for your message. Indeed the process is running in the Task Manager. I also believe it's something to do with the IIS as literally no website can be accessed - I tried it with a few of them (I have 3 domains, so I tried with 2 of them that weren't linked to SmarterMail). Nothing is accessed - the page either takes too long to respond or gives an error 503. The application pool was already changed to access things as the primary administrator and I modified that setting where it automatically turned off the application pool if there are crashes (sorry, can't think of its name at the moment).
If you could help me out I'd really appreciate it, and if you could tell me how I can cooperate and open a ticket for this, I'd be more than happy to do so.
In IIS Manager go to your Application Pools, select the Application Pool you created for SmarterMail and look at the ADVANCED SETTINGS. Under the "Process Model" section make sure that your "Identity" is set to "Network Service" (this is the default for new Application Pools). Then, go to your Sites and right-click on SmarterMail and choose EDIT PERMISSIONS. Both the "Network Service" and your "IIS_IUSRS" should be listed with "Read & Execute", "List Folder Contents", and "Read" permissions. If not click on the [EDIT] button and add them.
I've seen instances where .NET4.0 Framework gets damaged from a Windows Update and has to be re-registered. You can try the following command from a Cmd prompt:
C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe /i
and again at
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe /i
Otherwise you are going to have to resort to reviewing your Windows Logs in Event Viewer for clues as to why IIS is causing 503 errors.
Hello Scarab and thank you for your answer.
I hadn't added the 2 services to the Permissions. I successfully did so. However, this doesn't seem to fix it. I'll update with the whole story. so you guys can familiarize yourselves with it.
I ran the server to actually have exchange 2010 on it. After installing it, which was a pain, I messed with it for 3 days before saying "screw this". By then, OWA, exchange's outlook web application was accessible from anywhere but took no user input. The Exchange wasn't receiving mail so I thought it had something to do with the MX records, but it was the firewall, but I'm getting ahead of myself. After uninstalling Exchange, I tried smartermail, as it wasn't working, I uninstalled it and actually tried Exchange again, this time the OWA wasn't even working anymore, since beforehand I had removed the Default Website and re-creating it didn't fix it, so I removed Exchange yet again. After removing a dll startup from that Exchange today, there seemed to be no problems when accessing the website (my 2nd domain, for which I had tried to setup a simple html to test, browsing it from the IIS seemed to work after removing the DLL, while beforehand that didn't even work.) Now, bottom line is that I'll probably have to re-install this whole Windows because I had read somewhere that Exchange screws with anything it can get its hands on, so to speak. But even now, when I click on Smartermail interface I get an error the webpage is not available with details being "Google Chrome's connection to localhost was rejected. The website may be down, or your network may not be properly configured. Error code: ERR_CONNECTION_REFUSED." While on my laptop, when I access the domain associated with smartermail,, I get this in Firefox
The connection has timed out
The server at is taking too long to respond.
Everything on the IIS when it comes to smartermail has been set up. Event logs don't show any errors under Window Logs > Application.
If anyone would like screenshots of this whole thing, just tell me what you need, I'll be more than happy to supply.

Reply to Thread