Smartermail 7 not listening on port 25 nor port 110
Problem reported by A L Arredondo - January 5, 2015 at 11:40 AM
Not A Problem
I just recently migrated my Smartermail 7 installation from one W2003 32 bit Server to a different W2003 64 bit server having a different IP.  I installed a newer (the latest) 7.x download available from SmarterTools.  Everything appeared to go just fine and Smartermail was activated
 
All accounts and old email were immediately accessible and email could be sent to GMail etc.  The diagnostics are fine and SMTP appears to be OK from the administration screen.
 
The problem is that non-local email cannot be received by Smartermail. 
 
I ran netstat -abnp tcp on the server and nothing is listening on port 25.  The same goes for port 110 which is also supposed to be listening. 
 
I've reset the service, rebooted the server, turned off the firewall, uninstalled 7.x and reinstalled it.  But it just won't listen.
 
The only thing that I can think of is that I was running Windows 2003 32 bit before and now I am running Windows 2003 64 bit although Paul Blank mentioned that he was running version 7 on the 64 bit version of W2003.
 
Please note that I have the very latest service packs as well as the dot net libraries installed.
 
MORE OBSERVATIONS
 
When "telnet 104.222.97.139 25" is run:
"Connecting To 104.222.97.139...Could not open connection to the host, on port 25: Connect failed". This result is the same with Windows Firewall on or off.
 
If I turn off the firewall, I can telnet from the outside or otherwise connect to other services running on the server.  These services include MySQL, Firebird SQL, Sphinx, and Icecast which were not affected after changing servers.  It would appear that Windows Firewall is working correctly.
 
Sidenote, none of my websites are accessible by IP, they are resolved by host header.

14 Replies

Reply to Thread
0
Gary King Replied
If you moved servers, there's a likelyhood that you changed IP addresses -(unless you truly swapped boxes and configurations)... If the IP is different on the new box, login as admin, go to settings, bindings, ip addresses - pick the IP and edit it - set the hostname and enable the protocols you want enabled. You may have to restart the SmarterMail service. If you have the correct IP bound or kept the same one, check the firewall configuration on the new box or any security (antivirus) software running on it to make sure it allows those ports to answer. Hope it helps.
0
Paul Blank Replied
Good suggestions. Firewall and/or antivirus software are certainly possible culprits. Also, if you haven't already done so, make sure that nothing else is listening on those ports (another mail server program, perhaps).
0
A L Arredondo Replied
Gary, thank you for posting but I still have the same issue and I don't have AV software on the server. For Smartermail 7, there is nothing to bind your IP address except for 'SMTP OUT' but that is for outgoing email and the server can send email just fine. I never had this port listening problem on my W2003 32bit server. Has anyone used Smartermail 7 on W2003 64?
0
Paul Blank Replied
The settings are definitely there under "Settings/Bindings/IP Addresses". If you don't already know this: when SM services are running, you can (if Telnet client is installed on your server, which is really easy to do), you can type "telnet [ip address] 25" + Enter or "telnet localhost 25" + Enter, from a CMD prompt on the server to check if it's listening on that port. Type "quit" + Enter to end the session, BTW I had SM 7 on W2003 x64 (worked fine) but am on a much later version now.
0
Bruce Barnes Replied
Each individual domain may be bound to an IP address.   If you moved servers, you probably have new IP addresses.  Check each individual domain by highlighting the domain and EDITING it.
 
You should also make certain that, unless you are actually using IPV6, you have it DISABLED or NULL in all areas which reference IPV6
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Paul Blank Replied
BTW here's a quick and dirty way to find out if your SM + SMTP installation is OK, even if you can't get a response on port 25: Under Settings/Bindings/Ports, create an alternate SMTP port, say 26 (and then make sure that port is bound to the server IP address under Settings/Bindings/IP Addresses). Stop and restart SM services to be safe. Then you can repeat the Telnet query using 26 instead. If you get a response, you know something's messing with port 25 on the server, and SM very likely has nothing to do with it.
0
A L Arredondo Replied
Paul, thanks for your suggestions as well, my IP is 104.222.97.139 please try to connect, I think that something is not right.
0
A L Arredondo Replied
Here is the results of running telnet on the server: C:\Documents and Settings\Administrator>telnet 104.222.97.139 25 Connecting To 104.222.97.139...Could not open connection to the host, on port 25 : Connect failed I will try the port 26 suggestion this evening. For some reason, the 'settings/bindings' is not an option for me. I am using the Smartermail Admin account.
0
Gary King Replied
If you are ON the server (or remote desktop to it) and you do: telnet localhost 25 (and press enter) do you get a response? I tried your IP from the outside and get no response on port 25 - I do get an IIS under construction page on that IP, so something is mapping through your firewall. Is the Smartermail service running? May be a dumb question but valid nonetheless. If you can get there via telnet when you are ON the server, then perhaps it's a firewall mapping issue from the old server to the new? i.e., we don't know what IP your old box was and what the new one is... unless this is just hot on the internet vs behind a firewall.
0
A L Arredondo Replied
Looking at IPBindings section of mailConfig.xml, there is a section for OutboundDeliveryBinding containing "SpecifiedIP". I couldn't paste the section here since it gets stripped automatically.
0
A L Arredondo Replied
Thank you Bruce, you hit the nail on the head. I had been focusing on the 'Settings' option but I really don't understand how I overlooked this (feeling somewhat embarrassed). By the way, I may upgrade to version 13 in a few months after I upgrade to Windows 2012. I am curious to know if version 13 runs on W2003?
0
A L Arredondo Replied
I really wanted to say thanks to Paul and Gary for being so helpful.
0
Bruce Barnes Replied
Glad this helped solve your problem.

I have one instance of SmarterMail 13.X running on Server 2003, but, remember, all support, patches, and service packs for server 2003 END in JUNE, 2015, so it's time to start looking to upgrade.
 
We've moving all of our legacy 2003 servers directly to Server 2012.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Raj Replied
I had the same issue: Was able to send out email but not able to receive. telnet hostname 25 is partially working from remote machines. Its connecting (seems like at least) but no greeting . I get greeting "220 mail.host.com" when I telnet locally on the remote desktop. After spending many hours I found the issue: The culprit is the Windows Firewall default SMTP inbound rule. For some reason its not good. I simply disabled it and created new inbound rule to enable all traffic to port 25. This worked like a charm!!!

Reply to Thread