I can't login as system administrator. Only as domains adminitrator
Problem reported by Juan Antonio Tubio Capel - 3/5/2024 at 10:50 AM
Hello. I'm having this problem for a long time ago. But as I had this problem only on one computer and not on the other one that I have been using for administration, I didn't care much about this problem. But now I have the same problem on both computers.

I go to webmail login page and if I login with user@domain.com or user, I only can see the administration page for domain.com. I have the same user as administrator on most of my domains.

This is the url I'm send after login: webmail/interface/root#/settings/domain/domain-general-settings (for domain.com)

I checked my history and saw this url for system admin:

So, I go to login, put only user (not user@domain.com), I'm redirected to webmail/interface/root#/settings/domain/domain-general-settings and then I change url on the browser and try to go there: webmail/interface/root#/sysadmin/manage
And I get an error message: "User does not have rights to perform this action". Or sometimes I get a blank page.

So, my question is: Please, ¿How can I login as a system administrator? 

Thank you!

4 Replies

Reply to Thread
Patrick Jeski Replied
I find I can only login as system admin if I click “remember me”. 
Juan Antonio Tubio Capel Replied
Thank you. I tried but not worked for me.
Juan Antonio Tubio Capel Replied
Please, no one can help me?
Zach Sylvester Replied
Employee Post
Hey Juan, 

It sounds like your domain admin and your system admin have the same username and password. To resolve this you can do the following. 

  1. Stop the SmarterMail service. 
  2. Go to C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Settings
  3. Edit the administrators.json file
  4. Modify the username of the admin user and save the changes. 
  5. Start the SmarterMail service.
Let me know if this helps. 

Zach Sylvester System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com

Reply to Thread