Using SmarterMail FREE Edition to send mail from server: No such user here
Question asked by Ryan Zimmerman - 1/31/2024 at 9:30 AM
On our old server, the provider installed Smartermail Free edition and we used it to send mail from the mail server when someone filled out contact forms, placed orders etc.. We didn't need to manage a list of email users. However, we had to move to a new server running Windows Server 2019 and they no longer provide email setup services on the server.

Now when we try to send mail via say PHPMailer, and look at the output, we get the error

RCPT not accepted from server: 550 No such user here

What settings do we need to change to allow Smartermail to send mail from the web server to outside email addresses?

2 Replies

Reply to Thread
Zach Sylvester Replied
Employee Post
Hey Ryan, 

Thanks for reaching out to the community. Can you try going to Settings->Secuirty->Whitelist then whitelist the IP of the phpmailer client and check SMTP auth bypass then try again?

Zach Sylvester System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
Ryan Zimmerman Replied

Thank you for your response. I added the IP, then I tried the IP range of the server and still the same error. Also, the php client is on the same server as Smartermail. Also that is when not using SMTP Auth and port 25. I tried port 587 and it says "This is a submission only port. You must authenticate before sending mail" even in telnet

Reply to Thread