Build 8747 - Who is brave enough to upgrade?
Question asked by Stefano - 12/14/2023 at 8:34 AM
Hello guys,

Who is brave enough to upgrade to the latest version? 😁

23 Replies

Reply to Thread
Jay Altemoos Replied
I plan on installing it tonight. We have been running the beta versions on our production server and there's a fix we have been waiting for that's in the new version.
Tim Uzzanti Replied
Employee Post Marked As Answer

We have a surprisingly large number of customers running the new release.  It's been through the wringer over the last few months and its incredibly optimized.  We have seen customers servers use 25% less resources across the board compared to our previous production versions.  

Next, we are bringing SmarterMail to Linux in early 2024 along with even more features and functionality. Exciting time for SmarterMail!
Tim Uzzanti CEO SmarterTools Inc. (877) 357-6278 www.smartertools.com
Michael Replied
We're VERY excited to try today to resolve a number of open issues that were waiting on this version. Cheers to the SmarterTools team on the release! Thank you. We're going to update a backup machine that runs the free version today. Then our production server we plan to try either later today or over the weekend.
Stefano Replied
I know Tim, but I'm not brave enough to try it as soon as it was released 😉
Roger Replied
I can absolutely agree with Tim's comments here. There are some really great optimizations and bug fixes. The improvement in performance in particular is clearly noticeable. There are still a few issues that I currently have open with support and the developers in the tickets, but these problems also existed in the previous versions, so I see no reason why you shouldn't use the latest release. We have been using the beta versions for some time now.
Bruce Replied
We want to upgrade, but the API changes in the latest version of SmarterMail mean that we have to wait for a new provider to be written for the control panel software that we are using.
George To Replied
Hello Bruce,

May I know the details of "API changes" ?

I do not find it inside ChangeLog.
(except - Removed the API call for 'sender-trusted' when loading an email)

Thank you
Patrick Jeski Replied
Well, I tried it. Now I get "500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed." when I try to browse to my webmail. SMTP, IMAP and Submission all seem to be working, just IIS seems broke and I am not good enough with IIS to figure it out. I can browse to localhost:17017, though.
Michael Replied
Only strange thing we're seeing so far is that after upgrade the Application Pool's .NET CLR Version changes to "No Managed Code" - it had showed v4.0 previously.

We manually changed it back to v4.0. Was that right thing to do?

Anyone else see this?

Happened on 2 different Windows 2016 servers

Roger Replied
This could be because of missing ARR (IIS Application Request Routing) and URL rewrite rules

URL rewrite: write two rules in the IIS in your SmarterMail site under "URL Rewrite". One for HTTP and one for HTTPS:

Rewrite rule settings for HTTP:

Rewrite rule settings for HTTPS:

Patrick Jeski Replied
Thanks Roger. I don't speak German, but those rewrite rules appear to match what I have. I am curious though as to why the rules for both http: and https: rewrite to http:

I think the issue I'm having is with ASP.NET for .NET 8, I've installed it but I can't select it for the IIS role in server manager.

Robb Washeck Replied
We upgraded last night and my biggest issue was the new IIS Site and the appropriate settings.  The readme in the smarermail\mrs directory helped resolve my issue.  My biggest issue was finding the Application Request Routing settings which in my IIS setup is inside the Application Requesting Routing Cache then click Server Proxy Settings on the right.

Yes, I still have a few questions concerning IIS bindings and SSL Certificates but it's working this morning.
Thank you, Robb
echoDreamz Replied
Patrick, the rewrite to HTTP internally to the local SmarterMail process proxy (MailService.exe). The user still sees HTTPS where available regardless of the internal rewrite, it just communicates locally with HTTP.

Also, there is no selection of .net core in IIS, unlike .net framework, .net core has no "ties" to IIS like framework did. Your application pool is simply set to "No Managed Code" and the .net core ISAPI module takes over.
Patrick Jeski Replied
echoDreamz, thanks. That helps.
Robb, Outstanding.
For anyone else as inept as I am, it was ARR (see the readme.md that Robb mentioned), that was the only thing that wasn't installed. I then went through the manual setup instructions in the readme and all is cool.
Jay Dubb Replied
@Patrick Jeski - can you post the readme file, so that we can prepare before upgrading?  Our server is way too busy to upgrade, break, then be down while we try to sort through a readme file and implement its fixes.  

Our support line gets calls when we just do a 1-2 minute MailService.exe process restart, even late at night.  (users can be extremely impatient)  We'd get slammed with calls if something broke on upgrade.

Grady Werner Replied
Employee Post
For any of you that didn't get ARR setup automatically, we'd love to get a copy of your installer logs before the OS deletes them, so that we can figure out why your install didn't setup ARR the first time. They are in c:/users/[username]/AppData/Local/Temp/2/MSI####.txt

If you can grab those and send them in a support ticket with a link to this thread, it will help us solve the issue for others.

Regarding the readme, I've included a copy below:


# Manually Setting up a SmarterMail Proxy on IIS based on Application Request Routing and URL Rewrite Module 2

Note that the installer does these things for you. But if you need to set them up manually, below are the instructions.

### Point your IIS site to this folder

This folder ([INSTALLDIR]/MRS) contains the web.config file you will need, as well as a few error pages in case SmarterMail cannot be reached. 

Create a site in IIS and point it to this folder. 

Choose site bindings that are appropriate for your environment.

### Download and Install ARR and URL Rewrite Module 2

### Configure ARR

Open IIS

Click on your server name on the left

Click on the icon for Application Request Routing

Choose Server Proxy Settings from the right side

#### Configure it with the following settings:

- Enable proxy: ON
- Http version: Pass through
- Keep alive: ON
- Time-out (seconds): 1200
- Reverse rewrite host in response headers: OFF

- Custom Headers
  - Preserve client IP in the following header: X-Forwarded-For
  - Include TCP port from client IP: ON
  - Forwarding proxy header value: [blank]

- Cache Setting
  - Memory cache duration (seconds): 0
  - Enable disk cache: OFF
  - Enable request consolidation: OFF
  - Query string support: Do not cache

- Buffer Setting
  - Response buffer (KB): 4096
  - Response buffer threshold (KB): 0

- Proxy Chain
  - Proxy Server: [blank]

- Proxy Type
  - Use URL Rewrite to inspect incoming requests: OFF
  - Enable SSL offloading: ON

### Configure URL Rewrite Module 2

In IIS, Select your website from the left tree

Click the URL Rewrite icon

On the right side, choose "View Server Variables"

Add the following:


All other configuration comes from the web.config file and will be automatic
Grady Werner SmarterTools Inc. www.smartertools.com
Jay Dubb Replied
Thank you Grady.
Bert Garrett-Tuck Replied
I've just completed the upgrade to the 8747 build (from August's 8629 build)

Was having issues with high CPU usage (MailService consuming 1 CPU core 100% all the time) and also CLAMD not working properly - ref other posts about clamd/freshclam config file issues with 8.3 path names.
Also users reporting problems editing/deleting a calendar event in a series. Editing one instance of an event seems to screw it up. You can't cancel the instance or edit it again.

Did not RTFM properly -- thought I was remaining on the older version i.e. not the latest .NET 8 based product. That'll teach me.  7 hours later....

Overall the experience was fine. But not perfect. I had issues getting SmarterMail accepting/responding to IMAP and SMTP (both secure and insecure) connections. I thought it was a firewall issue, but it wasn't. Telnet/PuTTY couldn't connect (timeout) rather than connection refusal. Some Googleing and reviewing the logs was of no help. I think re-booting a couple of times was the "fix" for that.

My server is Win Std 2016. Dec cumulative update installed prior to upgrade. I'm pretty sure IIS already had URL rewrite and ARR modules installed as the server is used to host a couple of IIS sites as well as SM.

1. Uninstalled old SM version (after windows updates and a reboot).
2. Moved serive\clamd folder to clamd.old.  Same for "ham" folder (think that was left over from a build from long ago). Am glad I didn't delete those folders, reason will be shared below....
3. Installed new 8747 build. Existing IIS site [SmarterMail].
4. No issues with the proxying/ARR setup, no need to rename MRR folder. All that seemed to go perfectly.
5. Logged in OK. Realised this was the new version. "Oh dear".
6. Began to check services... SM reports everything is running but...
- Could connect via EWS/MAPI/ActiveSync & webmail OK.
- Could ***NOT*** connect via SMTP, IMAP and probably POP3 but didn't test that.
- clamd process is missing.  Looked for logs. It wasn't starting up properly. No signatures database found. Restored the service\clamd\share\clamav folder (where the DB lives) and it started up. Restarted MailService. No good. Applied the config file paths fix again, re-restarted MailService and ClamD process is back again!
So the issue here is that an upgrade doesn't include the necessary virus DBs and still uses old 8.3 file path names in the .conf files that seem to be causing issues.
7. Troubleshooting the IMAP/SMTP connectivity issues was hard. I could send/receive mail externally when connected via MAPI, ActiveSync and webmail. Couldn't connect to IMAP from Outlook or a smartphone mail client. Figured it was a bindings issue as was affecting both insecure and SSL connections.
8. Looked at the new SSL certs menu. There was some sort of contention/issue with the existing .PFX file I export and use for the secure protocol bindings. The page/second tab reported it couldn't open the .PFX file and trying to change the password on the first tab did nothing - Save button remained greyed out. .json setting file had some error in it saying it couldn't open the certificate.
9. Enabled the fancy new SSL certificates thing and fed in all the required options... Then realised what it was doing and regretted it. Turned it off.
10. This screw up somehow helped to fix the PFX certificate recognition issue. Had to go into Windows Certificates management, remove the duplicate cert that had been generated, and could now input the password on the first tab which then was able to open the PFX and all was well.... though still no IMAP connectivity....
11. Looked through SM logs and extensive googling. Thought it might have been firewall but temporarily disabling windows firewall solved nothing.
12. Removed some weird IPv6 IPs from the bindings page. Went through all the bindings. They looked OK. Still not fixed.
13. Re-started MailService again. Still not fixed.
14. Rebooted server.  IMAP connectivity!  Fixed!
15. Login page logo had been trashed/removed. Re-uploaded logo.
16. MailService and clamd are both running. No 100% of 1 CPU core being used. Re-set the anti-SPAM settings back to defaults and will configure all that again along with a SpamAssasin server which is one of my projects for the summer break.

Now I have to write some emails to customers explaining the UI changes and to re-test their calendar appointment cancellations/deletes to see if that is properly resolved.
Holding back just yet....
Tan Replied
Upgraded one of my client smartermail to latest build, password all went missing.

Need to reset every single account manually. Quota strangely were all set to 100MB and can only be updated after changing the password.

Not sure is it due to upgrading from older build. Read all the important before upgrading and didnt see any major issues.

Already log ticket will share more detail. I think because the build is much older and i suspect during the many build release it had to convert the user config into settings.json file causing this corruption but still want to share it out first.

What is the previous build you started upgrading from?
Gabriele Maoret - Head of SysAdmins at SERSIS Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
Stefano Replied
@Tim: it seems a corruption of some JSON file.
Tan Replied
@Gabriele Maoret - SERSIS, that will be Build 7496

Reply to Thread