How can I detect spam from my own email address being that is being spoofed?
Question asked by Brantz - 10/25/2023 at 9:38 AM
Hi - I've been having an ongoing problem with spam that has spoofed my own SmarterMail address (e.g. hundreds of "I RECORDED YOU!" scam emails).  It seems that because my address is also in my contacts, the spam checks just give it a pass (Trusted Sender - Contact), regardless of failing the SpamAssassin and many other checks.  I've been keeping current with the updates and am currently running Build 8664 (Sep 21, 2023).  How can I solve this?  Thanks!

4 Replies

Reply to Thread
Zach Sylvester Replied
Employee Post Marked As Answer
Hey Brantz, 

This is most commonly caused by missing DNS records and bad settings or a compromised account on the domain. 
Let's start with settings. 

  • Do you have Require SMTP authentication turned on for the domain? This is located in Manage->Domain.com->Secuirty 
  • Do you have "Enable domain's SMTP auth setting for local deliveries" turned on? If not then it doesn't require authentication to login as one of your users and send an email to a local user. This is located in Settings->Protocols->SMTP-IN. 
  • Do you have good password requirements and is everyone on your domain in compliance with your policy? You can change this by domain by going to Manage->Domains->Domain.com->Password requirements or you can change it for all domains by going to Settings->Password Requirments. 
  • Do you have DMARC enabled? This is located in Settings->Antispam If this is disabled then your DMARC policy will not be followed. 

Let's move to the DNS part next. Do you have SPF, DKIM, and DMARC setup for your domain?
If not then I recommend doing so and once you verify that all is working change the DMARC policy to reject that way external emails with your email address will be rejected. 

Please let me know if this helps. 


Zach Sylvester System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
Brantz Replied
Thanks Zach - I had everything set per your instructions except for "Enable domain's SMTP auth setting for local deliveries" which I have now turned on.  Hopefully this resolves it!  Thanks again.

Brantz Replied
As a follow-up, this change seems to have resolved the problem.  Thanks again!
Andrea Free Replied
Employee Post
Thanks for the follow-up, Brantz! That's great to hear. 
Andrea Free SmarterTools Inc. 877-357-6278 www.smartertools.com

Reply to Thread