1
SM 8664: I still have some users whose Outlook MAPI synchronization doesn't work
Problem reported by Gabriele Maoret - SERSIS - 10/5/2023 at 3:39 PM
Submitted
I still have some users whose Outlook MAPI synchronization doesn't work

Specifically: I have two Smartermail servers all in version 8664.

On the first server I have almost 1000 different domains, with over 200 users connected in MAPI (not on all domains, only on about fifty) and at the moment only 1 user in a domain of 24 users is not synchronizing correctly, all the others are working Well.

On the second server I only have 1 domain with 17 users, all in MAPI. Here too only 1 user does not work.

The other protocols IMAP, EWS (emClient) and EAS seem to work fine.

Webmail is OK.

Doing a complete Outlook cleanup ( https://portal.smartertools.com/kb/a3487/how-to-thoroughly-replace-your-mapi-account.aspx ) does not solve the problem.

Even doing "resync all user protocols" doesn't solve the problem with these two users.

Tried on 3 different PCs with different versions of Outlook (2019, 2021 and 365, all with Italian localization), I always have the same problem.

I currently have a ticket with RSAA open, but SmarterTools hasn't found a solution yet.

At the beginning they all worked well, then a few weeks ago (I don't know the exact date, it could even be a few months, given that the customer didn't report it immediately...) the first one started having problems.
A few days ago the second one...
I sincerely hope this doesn't start happening to some other users!

Anyone have suggestions?
Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)

17 Replies

Reply to Thread
0
Brian Bjerring-Jensen Replied
Look at the physical setup at the user pc. DNS or some other things....

What is the size of his mailbox?
0
Gabriele Maoret - SERSIS Replied
The setup of the PCs is Ok. I can confirm that because I tested with other accounts and all work fine.

The size of the two mailboxes with issue is approximately 15GB for one and 2GB for the second.
I have bigger mailboxes (many are over 40GB) and no issue at all with them (tested on the same PCs...).


Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Mike Mulhern Replied
Is this a new sync or old?  

I've run into problems with larger mailboxes where in MAPI > Outlook sync we need to begin cache @ 2 weeks and then expand to a greater cache over time once the 2 week initial Outlook sync is complete otherwise Outlook just never finishes the sync.  

I've let a mailbox try to sync with an Outlook cache of 3 months try from Friday night to Monday morning and never complete sync or work properly
0
Gabriele Maoret - SERSIS Replied
That's an old account.
It was working fine till a few weeks (months?...) ago...
Then it started to not sync...
Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Mike Mulhern Replied
Maybe the re-sync behavior is the same as a new sync?  Wipe clean and start fresh?  Just a thought/idea...
0
Gabriele Maoret - SERSIS Replied
@Mike Mulhern:

Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Brian Bjerring-Jensen Replied
Do any of these users have an real microsoft exchange account on 365 attached to the profile?
0
Gabriele Maoret - SERSIS Replied
No, only SmarterMail.

None of them have ever had 365 before either


I add and better specify the 2 problems (which are not the same...):

Folders partially synchronize with the first user's outlook. Every now and then something synchronizes, but never everything.
Tried on different PCs it always does the same thing.
No workaround discovered so far.

With the other user Outllok goes into error and doesn't even open.
But in this case I discovered a workaround: if I configure another empty email account (a local account on PST is enough) and put the SmarterMail account as secondary, then it works... Tried on different PCs it always does the same thing.
It's a very strange case...
Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Brian Bjerring-Jensen Replied
Have you tried and reset the entire pc so its clean before you install office/outlook and then try again.??
0
Gabriele Maoret - SERSIS Replied

Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Brian Bjerring-Jensen Replied
Complete pc back to factory default I mean :)


0
Gabriele Maoret - SERSIS Replied
I didn't explain myself well, sorry.

Those were 3 PCs of mine (not the customer's) completely clean and formatted from scratch on which I did some tests...
Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Brian Bjerring-Jensen Replied
Ahh okay. All 64 bit outlook??
0
Gabriele Maoret - SERSIS Replied
Yes

Gabriele Maoret - Head of SysAdmins at SERSIS
Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Brian Bjerring-Jensen Replied
Are there any special characters in his/hers account or domain?
0
Brian Bjerring-Jensen Replied
Can you run this and check again?

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover]
"ExcludeExplicitO365Endpoint"=dword:00000001
"ExcludeHttpRedirect"=dword:00000001
"ExcludeHttpsRootDomain"=dword:00000001
"ExcludeScpLookup"=dword:00000001

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover\RedirectServers]
"your mailserver.com"=hex(0):



0
Oliver Schulz Replied
same here. I have a new SM server and if you connect through MAPI, Server CPU goes up to 100% and Sync doesn`t work very well.

I can confirm that eM Client on Mac and Windows works very well, also EAS and Webmail. 


Also RSAA and Ticket open. 

Reply to Thread