3
Always show images from this sender – doesn't work
Problem reported by kevind - 1/10/2023 at 9:52 AM
Submitted
I have 3 messages from the same sender in my Inbox.  On the 1st message, I click "always show images from this sender" which displays the images. Good.

But when I go to the next message from the same sender, it doesn't display images.  Instead it shows the same message at the top:

Show images or always show images from this sender.

FWIW, putting both of these hyperlinks in the same sentence is kind of confusing. How about splitting the message into 2 or better yet, make buttons or a drop-down with all the options:
  • Unsubscribe
  • Show images
  • Always show images from this sender
  • etc.

16 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Hi Kevind, can you check the return-path/from on those messages in their raw content? I did a quick test here from a sender I have several messages from and after clicking Always show messages from this sender I see images in all of their emails.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
kevind Replied
The Return-Path: is the same for the email address, but the big long string inside the brackets are different:

Return-Path: noreply@amazon.com"><asdfhioasfhosiadufs@amazon.com>
Return-Path: noreply@amazon.com"><werwewersfgosiadufs@amazon.com>
For another message, the The Return-Path: is identical and it still doesn't work.

Try it for some messages that are sent by big names (Costco, Southwest, Hilton, Amazon, etc.) and I'm sure you'll be able to duplicate.

Kevin
0
Zach Sylvester Replied
Employee Post
Hey Kevind, 

I understand your situation here. You'd like to be able to allow inline images from the entire Amazon domain. However, there is no allow inline images from these domains option. 
As a workaround, you can add the Amazon.com domain to your trusted senders in webmail to do this go to Settings->Spam Filtering->Trusted Domains.

I tested this and it will show emails coming from amazon with images without having to do anything extra besides adding them there. 

Please let me know if this helps. 

Kind Regards, 
Zach Sylvester
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Kyle Kerst Replied
Employee Post
So far Kevind I can't replicate, once I mark it for a from address it shows images for all of them. These are older messages I've used for testing though so let me generate some new ones and I'll let you know what I find out. If its working the way you described though I could see this being a bug for sure.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
kevind Replied
Zach, I don't want to whitelist the entire Amazon domain. I just used that as an example.

I can get 4 messages from the same sender for 2FA, let's say to login to the bank.  I click on the 1st one to always allow images, then click the 2nd message and it doesn't show images.

Now we're currently running Build 8392 (Dec 23, 2022), so maybe it's been fixed in the latest version.
2
kevind Replied
Also, where does a person go to review their list of 'allow image' senders?

Thanks,
2
kevind Replied
Were you able to replicate? If not, here's an idea...

Look at all your messages from Amazon in 2022 that your packages were delivered. They are all from order-update@amazon.com. When you click Always show messages from this sender, it works on the first message, but not the rest.

Using Build 8405 (Jan 5, 2023).
2
kevind Replied
Known issue?
2
Kyle Kerst Replied
Employee Post
Hey there Kevin, sorry for the delay on this! I did some testing on the follow up scenario you outlined but couldn't replicate it there either. I believe we have some fixes/improvements coming in and around these areas though so can I have you test it again in the latest build and let me know if that helps? If not, I'm going to get a ticket created for you on this so we can dig in further. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
kevind Replied
Just tested this morning and it's still broken for me. Using Build 8426.

But I have another clue. Next to the From address is an exclamation point that the sender cannot be verified. So maybe that's why it doesn't work.

This message is in the pop up next to the From address:
The sender of this email cannot be verified
? DMARC Not Available
? SPF Not Available
? DKIM Not Available

But looking at the message source, I see:
SPF [Pass]: 0, DKIM [Pass]: -5  plus some other spam checks

We are running this beta on a separate server with a few mailboxes that are aliased on our production SmarterMail server. It's always worked fine in the past.
1
Kyle Kerst Replied
Employee Post
That may definitely have something to do with it as I know we're more careful about displaying images/avatars/etc for senders who can't be verified. This email is likely having its spam checks skipped, resulting in the identity check not being able to confirm where it is coming from. Do you have your gateways added to Settings>Antispam>IP Bypasses to ensure the spam checks aren't being run against them instead?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
kevind Replied
Yes, gateways are added to IP Bypass.

Viewing the message source, in the X-SmarterMail-SmartHostSpam: line, it has:
SPF [Pass] & DKIM [Pass]

So why does it say "SPF Not Available" in the webmail view?  Maybe that's another bug.

Also, I can completely sign out, sign back in, and it still displays images for the  original message, but not from the 2nd message from the same sender.

Tried "allow remote content from this sender" in Thunderbird for these same messages and it worked fine.
1
Kyle Kerst Replied
Employee Post
Do you have the SPF spam check disabled on the primary mail server? In that case you're getting the SPF results from the gateway, but because the check is disabled at the primary level those checks aren't being done and we're not confirming the validity of the sender. I think just saw a task on something in this area so this might be accounted for in the future. Let me do some testing on that setup and I'll let you know what I find out!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
kevind Replied
As far as I know, SPF is not disabled on the primary server.  It says SPF Pass right in the source of the message, so why does it matter if it comes from the gateway or the primary server? Isn't that one of the reasons to run a gateway – offload spam checks and other workloads from the primary?
2
Kyle Kerst Replied
Employee Post
Sorry for the delay on this. I'm going to set up some more detailed testing on this and will follow up with you when I know more :)
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
kevind Replied
OK, great. Don't really think we have that unique of a setup, but here's an easy way to duplicate.

Set up an alias on your production server that goes to a mailbox on your beta server.

The message will say this in message source:
X-SmarterMail-SmartHostSpam: SPF [Pass] & DKIM [Pass]

But say this in webmail view:
? SPF Not Available

Reply to Thread