1
Why SmarterMail greps private IP to do reversed dns checked
Question asked by Juan Lai - 12/12/2022 at 8:32 PM
Answered
Hello All,
     We have the latest SmarterMail and declude installed. And enabled X-Identify for both incoming and outbound mail:
   Any mail host received mail from our host now identified our private IP instead of mail server IP to
run RDNS and SPF check and led the result to fail. ( the server receiving email is also a SmarterMail host). Even they set our mail server ip to IP Bypass won't work. The SmarterMail host will only process sender client IP to check. 
   But if we sent the email to Gmail, the gmail is able to grep the mail host IP but not sender's private IP. (we fixed DKIM issue last Friday)
   Where we and they can check else?  We temporarily requested them to set all of our client IPs to IP Bypass. But this is not a solution....Thank you!

rds
Juan Lai

4 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
I believe you should be able to modify this setting right here in Settings>Protocols>SMTP In which should prevent the sending user's client IP being appended to the received chain: 

Kyle Kerst
System/Network Administrator
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Tony Scholz Replied
Employee Post Marked As Answer
Hello, 

One of the first places you can look is the IP Bypass under settings -> antispam. If the IP is listed here it will be skipped for your spam checks and the next IP in line ( the private IP in this case ) will be scanned, If there are no more IPs in teh header the scan will end. 

I hope this helps. Thank you
Tony Scholz
System/Network Administrator
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Juan Lai Replied
Hello Tony,
   Why scan client IP to check spam? Most of the clients are behind the NAT using private IP. This will always lead to rDNS check failed. Won't it?
   By the way, we have set the ip to IP-Bypass list.  

And the mail we received:

And the situation you mentioned to scan the next IP (client IP) did not happen. It directly shows Trsuted Sender.
Is there any other reason and sloution?

rds
Juan Lai

 
0
Juan Lai Replied
Hello Kyle,
   I've set as your advise, and the server IP is also gone.

In fact, my question is why my server previous always be identify as private IP and checked the private IP for rDNS. But the other SmarterMail server sent us will identiy the correct server IP and everything is fine.  We are not able to force other servers to check our private IP for rDNS correctly. 

Reply to Thread